Skip to content
Laskyr

Plugins · media-player-addons-for-elementor · data as of 2026-11-04

Is Media Player Addons for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.11)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.11 or newer fixes all of them that state a fix.

Latest version
1.1.11
Last updated
2026-10-29
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Extend Elementor with powerful, customizable media players for audio, video, streaming & playlists. — by bPlugins

What to do

  1. Update to the latest version (1.1.11). Anything older than 1.1.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get media-player-addons-for-elementor --field=version shows what you run; wp plugin update media-player-addons-for-elementor updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-119365 · published 2026-10-30

Stored cross-site scripting (XSS) in Media Player Addons for Elementor (1.1.10 and older)

Affected
1.1.10 and older
Fixed in
1.1.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Media Player Addons for Elementor – Media Player widget for WP media-player-addons-for-elementor allows Stored XSS.This issue affects Media Player Addons for Elementor – Media Player widget for WP: from n/a through 1.1.10.

NVD CVE-2026-119365Patchstack advisory

medium 6.4 CVE-2025-9203 · published 2025-09-17

Stored cross-site scripting (XSS) in Media Player Addons for Elementor (1.0.5 and older)

Affected
1.0.5 and older
Fixed in
1.0.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Media Player Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'subtitle_ssize', 'track_title', and 'track_artist_name' parameters in version 1.0.5. This is due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9203Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Media Player Addons for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/media-player-addons-for-elementor"><img src="https://laskyr.com/plugins/media-player-addons-for-elementor/badge.svg" alt="Media Player Addons for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit