Skip to content
Laskyr

Plugins · media-library-downloader · data as of 2026-11-04

Is Media Library Downloader safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.4.1 or newer fixes all of them that state a fix.

Latest version
1.4.3
Last updated
2026-07-30
Active installs
5,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Professional media download solution with bulk operations, smart management, and enterprise-grade security for WordPress — by M.Code

What to do

  1. Update to the latest version (1.4.3). Anything older than 1.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get media-library-downloader --field=version shows what you run; wp plugin update media-library-downloader updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-62734 · published 2025-12-09

Cross-site request forgery (CSRF) in Media Library Downloader (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in M.Code Media Library Downloader media-library-downloader allows Cross Site Request Forgery.This issue affects Media Library Downloader: from n/a through <= 1.4.0.

NVD CVE-2025-62734Patchstack advisory

medium 4.3 CVE-2025-46519 · published 2025-04-24

Missing authorization check in Media Library Downloader (1.3.1 and older)

Affected
1.3.1 and older
Fixed in
1.3.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in M.Code Media Library Downloader media-library-downloader allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Media Library Downloader: from n/a through <= 1.3.1.

NVD CVE-2025-46519Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Media Library Downloader vulnerability status badge
<a href="https://laskyr.com/plugins/media-library-downloader"><img src="https://laskyr.com/plugins/media-library-downloader/badge.svg" alt="Media Library Downloader vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit