Skip to content
Laskyr

Plugins · maxi-blocks · data as of 2026-11-04

Is MaxiBlocks Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.3)

As of 2026-11-04. 5 issues are on record for older versions; version 2.1.10 or newer fixes all of them that state a fix.

Latest version
2.2.3
Last updated
2026-09-02
Active installs
600+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Build professional WordPress sites faster. All features free forever. No locked blocks. Optional Cloud Library saves you time. — by Christiaan Pieterse

What to do

  1. Update to the latest version (2.2.3). Anything older than 2.1.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get maxi-blocks --field=version shows what you run; wp plugin update maxi-blocks updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-6378 · published 2026-05-02

Stored cross-site scripting (XSS) in MaxiBlocks Builder (2.1.9 and older)

Affected
2.1.9 and older
Fixed in
2.1.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Maxi Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `/wp-json/maxi-blocks/v1.0/style-card` REST API endpoint in all versions up to, and including, 2.1.9 due to insufficient input sanitization and output escaping of the `sc_styles` parameter. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts that execute on every page where the plugin's style card styles are loaded, including across the entire WordPress admin panel.

NVD CVE-2026-6378Wordfence advisorygithub.comPlugin source

medium 5.3 CVE-2026-2028 · published 2026-04-24

Missing authorization check in MaxiBlocks Builder (2.1.8 and older)

Affected
2.1.8 and older
Fixed in
2.1.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MaxiBlocks Builder plugin for WordPress is vulnerable to arbitrary media file deletion due to insufficient file ownership validation on the 'maxi_remove_custom_image_size' AJAX action in all versions up to, and including, 2.1.8. This makes it possible for authenticated attackers, with Author-level access and above, to delete arbitrary files in the wp-content/uploads directory, including files uploaded by other users and administrators.

NVD CVE-2026-2028Wordfence advisoryCode change (fix)github.comPlugin source

medium 5.0 CVE-2025-58968 · published 2025-09-22

Missing authorization check in MaxiBlocks Builder (2.1.3 and older)

Affected
2.1.3 and older
Fixed in
2.1.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Christiaan Pieterse MaxiBlocks maxi-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects MaxiBlocks: from n/a through <= 2.1.3.

NVD CVE-2025-58968Patchstack advisory

high 8.8 CVE-2025-47601 · published 2025-06-07

Privilege escalation in MaxiBlocks Builder (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Christiaan Pieterse MaxiBlocks maxi-blocks allows Privilege Escalation.This issue affects MaxiBlocks: from n/a through <= 2.1.0.

NVD CVE-2025-47601Patchstack advisory

high 8.1 CVE-2024-6885 · published 2024-07-23

Arbitrary file deletion in MaxiBlocks Builder (1.9.2 and older)

Affected
1.9.2 and older
Fixed in
1.9.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MaxiBlocks: 2200+ Patterns, 190 Pages, 14.2K Icons & 100 Styles plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the maxi_remove_custom_image_size and maxi_add_custom_image_size functions in all versions up to, and including, 1.9.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).

NVD CVE-2024-6885Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MaxiBlocks Builder vulnerability status badge
<a href="https://laskyr.com/plugins/maxi-blocks"><img src="https://laskyr.com/plugins/maxi-blocks/badge.svg" alt="MaxiBlocks Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit