Plugins · materialis-companion · data as of 2026-11-04
Is Materialis Companion safe? Known vulnerabilities and latest version
- Latest version
- 1.3.57
- Last updated
- 2026-08-12
- Active installs
- 6,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
The Materialis Companion plugin adds drag and drop page builder functionality to the Materialis theme. — by Horea Radu
What to do
- Update to the latest version (1.3.57). Anything older than 1.3.53 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get materialis-companion --field=version shows what you run; wp plugin update materialis-companion updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-24543 · published 2026-01-23
Missing authorization check in Materialis Companion (1.3.52 and older)
- Affected
- 1.3.52 and older
- Fixed in
- 1.3.53
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Horea Radu Materialis Companion materialis-companion allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Materialis Companion: from n/a through <= 1.3.52.
medium 5.4 CVE-2024-4707 · published 2024-06-06
Stored cross-site scripting (XSS) in Materialis Companion (1.3.41 and older)
- Affected
- 1.3.41 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Materialis Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's materialis_contact_form shortcode in all versions up to, and including, 1.3.41 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-4707Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2022-4762 · published 2023-02-06
Stored cross-site scripting (XSS) in Materialis Companion (older than 1.3.40)
- Affected
- older than 1.3.40
- Fixed in
- 1.3.40
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Materialis Companion WordPress plugin before 1.3.40 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Recent activity
- 2026-08-12 — latest release on wordpress.org (1.3.57).
- 2026-01-23 — Missing authorization check disclosed (CVE-2026-24543), fixed in 1.3.53.
- 2024-06-06 — Stored cross-site scripting (XSS) disclosed (CVE-2024-4707), fix version not stated.
- 2023-02-06 — Stored cross-site scripting (XSS) disclosed (CVE-2022-4762), fixed in 1.3.40.
Get an email when Materialis Companion has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Materialis Companion (materialis-companion) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Horea Radu (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/materialis-companion (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/materialis-companion"><img src="https://laskyr.com/plugins/materialis-companion/badge.svg" alt="Materialis Companion vulnerability status"></a>