Skip to content
Laskyr

Plugins · marquee-addons-for-elementor · data as of 2026-11-04

Is Marquee Addons for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.92)

As of 2026-11-04. 2 issues are on record for older versions; version 3.8.3 or newer fixes all of them that state a fix.

Latest version
3.9.92
Last updated
2026-10-27
Active installs
20,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Marquee Addons is a smooth video, text, image, and testimonial marquee carousel loop plugin for Elementor on WordPress — by Debuggers Studio

What to do

  1. Update to the latest version (3.9.92). Anything older than 3.8.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get marquee-addons-for-elementor --field=version shows what you run; wp plugin update marquee-addons-for-elementor updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-8199 · published 2025-12-13

Stored cross-site scripting (XSS) in Marquee Addons for Elementor (2.4.3 and older)

Affected
2.4.3 and older
Fixed in
3.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MarqueeAddons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Testimonial Marquee widget in all versions up to, and including, 2.4.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8199Wordfence advisoryCode change (fix)wordpress.org

medium 6.5 CVE-2025-62923 · published 2025-10-27

Cross-site scripting (XSS) in Marquee Addons for Elementor (3.8.2 and older)

Affected
3.8.2 and older
Fixed in
3.8.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Debuggers Studio Marquee Addons for Elementor marquee-addons-for-elementor allows DOM-Based XSS.This issue affects Marquee Addons for Elementor: from n/a through <= 3.8.2.

NVD CVE-2025-62923Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Marquee Addons for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/marquee-addons-for-elementor"><img src="https://laskyr.com/plugins/marquee-addons-for-elementor/badge.svg" alt="Marquee Addons for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit