Plugins · marketking-multivendor-marketplace-for-woocommerce · data as of 2026-11-04
Is MarketKing safe? Known vulnerabilities and latest version
- Latest version
- 2.1.80
- Last updated
- 2026-10-20
- Active installs
- 700+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6.20+
MarketKing is the modern, next-gen multivendor marketplace platform. Build your dream marketplace with stunning UX and powerful features. — by KingsPlugins
What to do
- Update to the latest version (2.1.80). Anything older than 2.1.80 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get marketking-multivendor-marketplace-for-woocommerce --field=version shows what you run; wp plugin update marketking-multivendor-marketplace-for-woocommerce updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-111847 · published 2026-10-22
Missing authorization check in MarketKing (2.1.72 and older)
- Affected
- 2.1.72 and older
- Fixed in
- 2.1.80
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Kings Plugins MarketKing marketking-multivendor-marketplace-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects MarketKing: from n/a through 2.1.72.
medium 5.3 CVE-2026-94080 · published 2026-09-23
Missing authorization check in MarketKing (2.1.70 and older)
- Affected
- 2.1.70 and older
- Fixed in
- 2.1.72
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in MarketKing <= 2.1.70 versions.
medium 5.3 CVE-2026-85311 · published 2026-09-04
Missing authorization check in MarketKing (2.1.60 and older)
- Affected
- 2.1.60 and older
- Fixed in
- 2.1.70
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Kings Plugins MarketKing allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects MarketKing: from n/a through 2.1.60.
medium 5.3 CVE-2026-27399 · published 2026-07-23
Missing authorization check in MarketKing (2.1.40 and older)
- Affected
- 2.1.40 and older
- Fixed in
- 2.1.50
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in MarketKing <= 2.1.40 versions.
medium 6.5 CVE-2025-58702 · published 2025-09-22
Stored cross-site scripting (XSS) in MarketKing (2.0.92 and older)
- Affected
- 2.0.92 and older
- Fixed in
- 2.1.00
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WebWizards MarketKing marketking-multivendor-marketplace-for-woocommerce allows Stored XSS.This issue affects MarketKing: from n/a through <= 2.0.92.
medium 4.4 CVE-2024-13519 · published 2025-01-18
Stored cross-site scripting (XSS) in MarketKing (1.9.80 and older)
- Affected
- 1.9.80 and older
- Fixed in
- 2.0.00 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MarketKing — Ultimate WooCommerce Multivendor Marketplace Solution plugin for WordPress is vulnerable to Stored Cross-Site Scripting via plugin's settings in all versions up to, and including, 1.9.80 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Shop Manager-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
medium 5.3 CVE-2024-12413 · published 2024-12-25
Missing authorization check in MarketKing (2.0.00 and older)
- Affected
- 2.0.00 and older
- Fixed in
- 2.0.25 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MarketKing — Ultimate WooCommerce Multivendor Marketplace Solution plugin for WordPress is vulnerable to unauthorized access due to missing capability checks on several functions like 'marketking_delete_team_member', 'marketkingrejectuser', 'marketking_save_profile_settings', and many more in all versions up to, and including, 2.0.00. This makes it possible for unauthenticated attackers to delete users, update settings, approve users, and more.
Recent activity
- 2026-10-20 — latest release on wordpress.org (2.1.80).
- 2026-10-22 — Missing authorization check disclosed (CVE-2026-111847), fixed in 2.1.80.
- 2026-09-23 — Missing authorization check disclosed (CVE-2026-94080), fixed in 2.1.72.
- 2026-09-04 — Missing authorization check disclosed (CVE-2026-85311), fixed in 2.1.70.
Get an email when MarketKing has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MarketKing (marketking-multivendor-marketplace-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by KingsPlugins (2 tracked)
Types found in this plugin: Missing authorization (5) · Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/marketking-multivendor-marketplace-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/marketking-multivendor-marketplace-for-woocommerce"><img src="https://laskyr.com/plugins/marketking-multivendor-marketplace-for-woocommerce/badge.svg" alt="MarketKing vulnerability status"></a>