Plugins · malcare-security · data as of 2026-11-04
Is MalCare WordPress Security Plugin safe? Known vulnerabilities and latest version
- Latest version
- 6.81
- Last updated
- 2026-10-30
- Active installs
- 100,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Get Bulletproof Security for your WordPress site. WordPress security plugin packed with comprehensive Firewall, malware scanner, cleaner & more. — by malcare
What to do
- Update to the latest version (6.81). Anything older than 6.72 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get malcare-security --field=version shows what you run; wp plugin update malcare-security updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-84776 · published 2026-09-03
Denial of service in MalCare WordPress Security Plugin (6.69 and older)
- Affected
- 6.69 and older
- Fixed in
- 6.72
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Denial of Service Attack in MalCare Security <= 6.69 versions.
high 8.1 CVE-2026-19718 · published 2026-08-26
Authentication bypass in MalCare WordPress Security Plugin (5.16 up to (not including) 6.65)
- Affected
- 5.16 up to (not including) 6.65
- Fixed in
- 6.65
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The BlogVault Backup & Staging WordPress plugin before 6.65, MalCare WordPress Security Plugin WordPress plugin before 6.65, The WP Remote WordPress Plugin WordPress plugin before 6.65 do not prevent unauthenticated users from obtaining data derived from the secret that binds a site to its remote management service, and generate that secret with a weak pseudo-random number generator, allowing attackers to recover it and gain administrative access to the site.
Recent activity
- 2026-10-30 — latest release on wordpress.org (6.81).
- 2026-09-03 — Denial of service disclosed (CVE-2026-84776), fixed in 6.72.
- 2026-08-26 — Authentication bypass disclosed (CVE-2026-19718), fixed in 6.65.
Get an email when MalCare WordPress Security Plugin has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MalCare WordPress Security Plugin (malcare-security) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Denial of service (1) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/malcare-security (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/malcare-security"><img src="https://laskyr.com/plugins/malcare-security/badge.svg" alt="MalCare WordPress Security Plugin vulnerability status"></a>