Skip to content
Laskyr

Plugins · makewebbetter-hubspot-for-woocommerce · data as of 2026-11-04

Is MWB HubSpot for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.8)

As of 2026-11-04. 2 issues are on record for older versions; version 1.6.8 or newer fixes all of them that state a fix.

Latest version
1.6.8
Last updated
2026-09-03
Active installs
6,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.0 · PHP 5.1+

Integrate WooCommerce with HubSpot’s free CRM, abandoned cart tracking, email marketing, marketing automation, analytics & more. — by MakeWebBetter

What to do

  1. Update to the latest version (1.6.8). Anything older than 1.6.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get makewebbetter-hubspot-for-woocommerce --field=version shows what you run; wp plugin update makewebbetter-hubspot-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-73396 · published 2026-08-18

Authentication bypass in MWB HubSpot for WooCommerce (1.6.7 and older)

Affected
1.6.7 and older
Fixed in
1.6.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Authentication in MWB HubSpot for WooCommerce <= 1.6.7 versions.

NVD CVE-2026-73396Patchstack advisory

high 8.8 CVE-2024-10591 · published 2025-01-30

Privilege escalation in MWB HubSpot for WooCommerce (1.5.9 and older)

Affected
1.5.9 and older
Fixed in
1.6.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MWB HubSpot for WooCommerce – CRM, Abandoned Cart, Email Marketing, Marketing Automation & Analytics plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the hubwoo_save_updates() function in all versions up to, and including, 1.5.9. This makes it possible for authenticated attackers, with Contributor-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.

NVD CVE-2024-10591Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MWB HubSpot for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/makewebbetter-hubspot-for-woocommerce"><img src="https://laskyr.com/plugins/makewebbetter-hubspot-for-woocommerce/badge.svg" alt="MWB HubSpot for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit