Plugins · makecommerce · data as of 2026-11-04
Is MakeCommerce for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.1.2
- Last updated
- 2026-11-03
- Active installs
- 3,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
Payments and shipping for WooCommerce stores in Estonia, Latvia, Lithuania and Finland. One contract, one bank account, all major banks and cards. — by MakeCommerce.net
What to do
- Update to the latest version (4.1.2). Anything older than 4.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get makecommerce --field=version shows what you run; wp plugin update makecommerce updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.2 CVE-2026-96817 · published 2026-09-30
Missing authorization check in MakeCommerce for WooCommerce (4.1.0 and older)
- Affected
- 4.1.0 and older
- Fixed in
- 4.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in MakeCommerce for WooCommerce <= 4.1.0 versions.
medium 6.1 CVE-2024-37509 · published 2024-07-21
Reflected cross-site scripting (XSS) in MakeCommerce for WooCommerce (3.5.1 and older)
- Affected
- 3.5.1 and older
- Fixed in
- 3.5.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Maksekeskus AS MakeCommerce for WooCommerce allows Reflected XSS.This issue affects MakeCommerce for WooCommerce: from n/a through 3.5.1.
Recent activity
- 2026-11-03 — latest release on wordpress.org (4.1.2).
- 2026-09-30 — Missing authorization check disclosed (CVE-2026-96817), fixed in 4.1.1.
- 2024-07-21 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-37509), fixed in 3.5.2.
Get an email when MakeCommerce for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MakeCommerce for WooCommerce (makecommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/makecommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/makecommerce"><img src="https://laskyr.com/plugins/makecommerce/badge.svg" alt="MakeCommerce for WooCommerce vulnerability status"></a>