Plugins · mainwp-child · data as of 2026-11-01
Is MainWP Child safe? Known vulnerabilities and latest version
- Latest version
- 6.4
- Last updated
- 2026-10-29
- Active installs
- 700,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
MainWP Child establishes a secure link between your WordPress sites and your self-hosted MainWP Dashboard, simplifying site management. — by mainwp
What to do
- Update to the latest version (6.4). Anything older than 6.2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mainwp-child --field=version shows what you run; wp plugin update mainwp-child updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-105436 · published 2026-10-08
PHP object injection in MainWP Child (6.2.1 and older)
- Affected
- 6.2.1 and older
- Fixed in
- 6.2.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in MainWP MainWP Child mainwp-child allows Object Injection.This issue affects MainWP Child: from n/a through 6.2.1.
high 8.1 CVE-2026-12255 · published 2026-07-27
Authentication bypass in MainWP Child (older than 6.1.2)
- Affected
- older than 6.1.2
- Fixed in
- 6.1.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The MainWP Child WordPress plugin before 6.1.2 does not verify the requester's identity in its site-registration request handler when password authentication has been disabled for the targeted account, allowing an unauthenticated attacker to obtain a valid authentication session as that account, including an administrator, by naming its login in a single registration request.
high 7.5 CVE-2026-27366 · published 2026-06-25
Missing authorization check in MainWP Child (6.1.1 and older)
- Affected
- 6.1.1 and older
- Fixed in
- 6.1.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in MainWP Child <= 6.1.1 versions.
high 8.1 CVE-2024-10783 · published 2024-12-13
Privilege escalation in MainWP Child (5.3.3 and older)
- Affected
- 5.3.3 and older
- Fixed in
- 5.3.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MainWP Child – Securely Connects to the MainWP Dashboard to Manage Multiple Sites plugin for WordPress is vulnerable to privilege escalation due to a missing authorization checks on the register_site function in all versions up to, and including, 5.2 when a site is left in an unconfigured state. This makes it possible for unauthenticated attackers to log in as an administrator on instances where MainWP Child is not yet connected to the MainWP Dashboard. IMPORTANT: this only affects sites who have MainWP Child installed and have not yet connected to the MainWP Dashboard, and do not have the unique security ID feature enabled. Sites already connected to the MainWP Dashboard plugin and do not have the unique security ID feature enabled, are NOT affected and not required to upgrade. Please note versions up to 5.3.3 contained a patch, though a bypass was discovered and not addressed until version 5.3.4.
NVD CVE-2024-10783Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 7.5 CVE-2023-3132 · published 2023-06-27
Information disclosure in MainWP Child (4.4.1.1 and older)
- Affected
- 4.4.1.1 and older
- Fixed in
- 4.4.1.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The MainWP Child plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 4.4.1.1 due to insufficient controls on the storage of back-up files. This makes it possible for unauthenticated attackers to extract sensitive data including the entire installations database if a backup occurs and the deletion of the back-up files fail.
high 7.2 CVE-2021-24877 · published 2021-11-23
SQL injection in MainWP Child (older than 4.1.8)
- Affected
- older than 4.1.8
- Fixed in
- 4.1.8
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- NVD analysis · score by NVD
Details from the advisory
The MainWP Child WordPress plugin before 4.1.8 does not validate the orderby and order parameter before using them in a SQL statement, leading to an SQL injection exploitable by high privilege users such as admin when the Backup and Staging by WP Time Capsule plugin is installed
Recent activity
- 2026-10-29 — latest release on wordpress.org (6.4).
- 2026-10-08 — PHP object injection disclosed (CVE-2026-105436), fixed in 6.2.2.
- 2026-07-27 — Authentication bypass disclosed (CVE-2026-12255), fixed in 6.1.2.
- 2026-06-25 — Missing authorization check disclosed (CVE-2026-27366), fixed in 6.1.2.
Get an email when MainWP Child has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MainWP Child (mainwp-child) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mainwp-child (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mainwp-child"><img src="https://laskyr.com/plugins/mainwp-child/badge.svg" alt="MainWP Child vulnerability status"></a>