Skip to content
Laskyr

Plugins · mainwp · data as of 2026-11-04

Is MainWP Dashboard safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.4.1)

As of 2026-11-04. 5 issues are on record for older versions; version 6.1.2 or newer fixes all of them that state a fix.

Latest version
6.4.1
Last updated
2026-11-03
Active installs
20,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.3+

Run updates, backups, security and reporting across all client sites from your own server. Keep data private and prove your value with branded reports … — by mainwp

What to do

  1. Update to the latest version (6.4.1). Anything older than 6.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mainwp --field=version shows what you run; wp plugin update mainwp updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.3 CVE-2026-57327 · published 2026-06-29

Missing authorization check in MainWP Dashboard (6.1.1 and older)

Affected
6.1.1 and older
Fixed in
6.1.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in MainWP <= 6.1.1 versions.

NVD CVE-2026-57327Patchstack advisory

medium 6.1 CVE-2016-15041 · published 2024-10-16

Stored cross-site scripting (XSS) in MainWP Dashboard (older than 3.1.3)

Affected
older than 3.1.3
Fixed in
3.1.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MainWP Dashboard – The Private WordPress Manager for Multiple Website Maintenance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘mwp_setup_purchase_username’ parameter in versions up to, and including, 3.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2016-15041Wordfence advisoryklikki.fiweb.archive.orgacunetix.com

medium 4.3 CVE-2024-1642 · published 2024-03-13

Cross-site request forgery (CSRF) in MainWP Dashboard (4.6.0.1 and older)

Affected
4.6.0.1 and older
Fixed in
5.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.6.0.1. This is due to missing or incorrect nonce validation on the 'posting_bulk' function. This makes it possible for unauthenticated attackers to delete arbitrary posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-1642Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2023-38519 · published 2023-12-20

SQL injection in MainWP Dashboard (4.4.3.3 and older)

Affected
4.4.3.3 and older
Fixed in
4.4.3.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in MainWP MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance.This issue affects MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance: from n/a through 4.4.3.3.

NVD CVE-2023-38519Patchstack advisory

medium 4.8 CVE-2023-6164 · published 2023-11-22

Content injection in MainWP Dashboard (4.5.1.2 and older)

Affected
4.5.1.2 and older
Fixed in
4.5.1.3 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance plugin for WordPress is vulnerable to CSS Injection via the ‘newColor’ parameter in all versions up to, and including, 4.5.1.2 due to insufficient input sanitization. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary CSS values into the site tags.

NVD CVE-2023-6164Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MainWP Dashboard vulnerability status badge
<a href="https://laskyr.com/plugins/mainwp"><img src="https://laskyr.com/plugins/mainwp/badge.svg" alt="MainWP Dashboard vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit