Plugins · maintenance-mode-based-on-user-roles · data as of 2026-11-04
Is Conditionnal Maintenance Mode for WordPress safe? Known vulnerabilities and latest version
- Latest version
- 2.0.0
- Last updated
- 2025-11-26
- Active installs
- fewer than 10
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.7.11
This plugin allows the administrator to enable or disable maintenance mode for selected user roles and customize the maintenance message. — by Walid Sadfi
What to do
- Update to the latest version (2.0.0). Anything older than 2.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get maintenance-mode-based-on-user-roles --field=version shows what you run; wp plugin update maintenance-mode-based-on-user-roles updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-12586 · published 2025-11-25
Cross-site request forgery (CSRF) in Conditionnal Maintenance Mode for WordPress (1.0.0 and older)
- Affected
- 1.0.0 and older
- Fixed in
- 2.0.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Conditional Maintenance Mode for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.0. This is due to missing nonce validation when toggling the maintenance mode status. This makes it possible for unauthenticated attackers to enable or disable the site's maintenance mode via a forged request granted they can trick an administrator into performing an action such as clicking on a link.
NVD CVE-2025-12586Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2025-11-26 — latest release on wordpress.org (2.0.0).
- 2025-11-25 — Cross-site request forgery (CSRF) disclosed (CVE-2025-12586), fixed in 2.0.0.
Get an email when Conditionnal Maintenance Mode for WordPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Conditionnal Maintenance Mode for WordPress (maintenance-mode-based-on-user-roles) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/maintenance-mode-based-on-user-roles (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/maintenance-mode-based-on-user-roles"><img src="https://laskyr.com/plugins/maintenance-mode-based-on-user-roles/badge.svg" alt="Conditionnal Maintenance Mode for WordPress vulnerability status"></a>