Plugins · maintenance · data as of 2026-11-01
Is Maintenance safe? Known vulnerabilities and latest version
- Latest version
- 4.32
- Last updated
- 2026-08-16
- Active installs
- 1+ million
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.2+
Great looking maintenance, coming soon & under construction pages. Put your site under maintenance in minutes. — by WebFactory
What to do
- Update to the latest version (4.32). Anything older than 4.03 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get maintenance --field=version shows what you run; wp plugin update maintenance updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.8 CVE-2021-24533 · published 2021-08-23
Cross-site scripting (XSS) in Maintenance (older than 4.03)
- Affected
- older than 4.03
- Fixed in
- 4.03
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Maintenance WordPress plugin before 4.03 does not sanitise or escape some of its settings, allowing high privilege users such as admin to se Cross-Site Scripting payload in them (even when the unfiltered_html capability is disallowed), which will be triggered in the frontend
Recent activity
- 2026-08-16 — latest release on wordpress.org (4.32).
- 2021-08-23 — Cross-site scripting (XSS) disclosed (CVE-2021-24533), fixed in 4.03.
Get an email when Maintenance has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Maintenance (maintenance) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/maintenance (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/maintenance"><img src="https://laskyr.com/plugins/maintenance/badge.svg" alt="Maintenance vulnerability status"></a>