Plugins · mailster · data as of 2026-11-04
Is Mailster WordPress Newsletter Plugin safe? Known vulnerabilities and latest version
- Latest version
- 2.0.3
- Last updated
- 2026-10-15
- Active installs
- 7,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Free WordPress compatibility tester for Mailster. Check your site before buying the premium email newsletter plugin. — by EverPress
What to do
- Update to the latest version (2.0.3). Anything older than 4.1.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mailster --field=version shows what you run; wp plugin update mailster updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.
critical 9.1 CVE-2026-27064 · published 2026-07-23
Arbitrary file upload in Mailster WordPress Newsletter Plugin (4.1.17 and older)
- Affected
- 4.1.17 and older
- Fixed in
- 4.1.18
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Note: the source's version range goes past the newest Mailster WordPress Newsletter Plugin release on wordpress.org (2.0.3), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
Editor Arbitrary File Upload in Mailster <= 4.1.17 versions.
high 7.1 CVE-2025-64203 · published 2025-12-18
Reflected cross-site scripting (XSS) in Mailster WordPress Newsletter Plugin (4.1.14 and older)
- Affected
- 4.1.14 and older
- Fixed in
- 4.1.14
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Note: the source's version range goes past the newest Mailster WordPress Newsletter Plugin release on wordpress.org (2.0.3), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in EverPress Mailster mailster allows Reflected XSS.This issue affects Mailster: from n/a through < 4.1.14.
medium 6.1 CVE-2024-37433 · published 2024-07-22
Cross-site scripting (XSS) in Mailster WordPress Newsletter Plugin (4.0.9 and older)
- Affected
- 4.0.9 and older
- Fixed in
- 4.0.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Note: the source's version range goes past the newest Mailster WordPress Newsletter Plugin release on wordpress.org (2.0.3), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in EverPress Mailster mailster.This issue affects Mailster: from n/a through <= 4.0.9.
high 8.1 CVE-2024-32523 · published 2024-05-17
File inclusion in Mailster WordPress Newsletter Plugin (4.0.6 and older)
- Affected
- 4.0.6 and older
- Fixed in
- 4.0.7
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Note: the source's version range goes past the newest Mailster WordPress Newsletter Plugin release on wordpress.org (2.0.3), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in EverPress Mailster mailster.This issue affects Mailster: from n/a through <= 4.0.6.
medium 6.1 CVE-2024-30503 · published 2024-03-29
Cross-site scripting (XSS) in Mailster WordPress Newsletter Plugin (4.0.6 and older)
- Affected
- 4.0.6 and older
- Fixed in
- 4.0.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Note: the source's version range goes past the newest Mailster WordPress Newsletter Plugin release on wordpress.org (2.0.3), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in EverPress Mailster mailster.This issue affects Mailster: from n/a through <= 4.0.6.
Recent activity
- 2026-10-15 — latest release on wordpress.org (2.0.3).
- 2026-07-23 — Arbitrary file upload disclosed (CVE-2026-27064), fixed in 4.1.18.
- 2025-12-18 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-64203), fixed in 4.1.14.
- 2024-07-22 — Cross-site scripting (XSS) disclosed (CVE-2024-37433), fixed in 4.0.10.
Get an email when Mailster WordPress Newsletter Plugin has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Mailster WordPress Newsletter Plugin (mailster) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Arbitrary file upload (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mailster (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mailster"><img src="https://laskyr.com/plugins/mailster/badge.svg" alt="Mailster WordPress Newsletter Plugin vulnerability status"></a>