Plugins · mailpoet · data as of 2026-11-01
Is MailPoet safe? Known vulnerabilities and latest version
- Latest version
- 5.44.0
- Last updated
- 2026-10-27
- Active installs
- 500,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Send beautiful newsletters from WordPress. Collect subscribers with signup forms, automate your emails for WooCommerce, blog post notifications & more — by MailPoet
What to do
- Update to the latest version (5.44.0). Anything older than 5.33.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mailpoet --field=version shows what you run; wp plugin update mailpoet updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-57626 · published 2026-07-23
Cross-site request forgery (CSRF) in MailPoet (5.30.0 to 5.33.0)
- Affected
- 5.30.0 to 5.33.0
- Fixed in
- 5.33.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in MailPoet allows Cross Site Request Forgery. This issue affects MailPoet: from 5.30.0 through 5.33.0.
medium 4.8 CVE-2024-12743 · published 2025-05-15
Stored cross-site scripting (XSS) in MailPoet (older than 5.5.2)
- Affected
- older than 5.5.2
- Fixed in
- 5.5.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The MailPoet WordPress plugin before 5.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
medium 6.1 CVE-2024-10103 · published 2024-11-19
Stored cross-site scripting (XSS) in MailPoet (older than 5.3.2)
- Affected
- older than 5.3.2
- Fixed in
- 5.3.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
In the process of testing the MailPoet WordPress plugin before 5.3.2, a vulnerability was found that allows you to implement Stored XSS on behalf of the editor by embedding malicious script, which entails account takeover backdoor
medium 6.1 CVE-2019-11843 · published 2020-06-02
Cross-site scripting (XSS) in MailPoet (older than 3.23.2)
- Affected
- older than 3.23.2
- Fixed in
- 3.23.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The MailPoet plugin before 3.23.2 for WordPress allows remote attackers to inject arbitrary web script or HTML using extra parameters in the URL (Reflective Server-Side XSS).
Recent activity
- 2026-10-27 — latest release on wordpress.org (5.44.0).
- 2026-07-23 — Cross-site request forgery (CSRF) disclosed (CVE-2026-57626), fixed in 5.33.1.
- 2025-05-15 — Stored cross-site scripting (XSS) disclosed (CVE-2024-12743), fixed in 5.5.2.
- 2024-11-19 — Stored cross-site scripting (XSS) disclosed (CVE-2024-10103), fixed in 5.3.2.
Get an email when MailPoet has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MailPoet (mailpoet) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mailpoet (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mailpoet"><img src="https://laskyr.com/plugins/mailpoet/badge.svg" alt="MailPoet vulnerability status"></a>