Skip to content
Laskyr

Plugins · mailoptin · data as of 2026-11-04

Is MailOptin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.78.7)

As of 2026-11-04. 7 issues are on record for older versions; version 1.2.78.7 or newer fixes all of them that state a fix.

Latest version
1.2.78.7
Last updated
2026-10-13
Active installs
10,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create popup, optin forms using easy form builder & popup maker. Send automated email to subscribers — Mailchimp, ActiveCampaign, Campaign Monitor etc — by properfraction

What to do

  1. Update to the latest version (1.2.78.7). Anything older than 1.2.78.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mailoptin --field=version shows what you run; wp plugin update mailoptin updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-109515 · published 2026-10-16

Privilege escalation in MailOptin (1.2.78.6 and older)

Affected
1.2.78.6 and older
Fixed in
1.2.78.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.2.78.6 This is due to the `subscribe_to_email_list` endpoint accepting an attacker-supplied `optin_data[form_custom_field_mappings]` parameter without any allow-list validation on destination keys, allowing the attacker-controlled mapping to override the administrator's saved mapping and pass arbitrary `wp_users` column names — including `ID` and `user_pass` — directly into `wp_insert_user()` via the `subscribe()` function. This makes it possible for unauthenticated attackers to force `wp_insert_user()` into UPDATE mode on any existing account by supplying a target user's numeric `ID`, overwrite that account's password with a pre-hashed value of their choosing, and thereby take over any WordPress user account — including administrators — leading to full site compromise. Exploitation requires that a WordPress User Registration opt-in form is published somewhere on the site, though the form's UUID is visible in page source and no authentication, nonce, or capability check is required to reach the vulnerable endpoint.

NVD CVE-2026-109515Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-66703 · published 2026-08-06

Cross-site scripting (XSS) in MailOptin (1.2.78.0 and older)

Affected
1.2.78.0 and older
Fixed in
1.2.78.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in MailOptin <= 1.2.78.0 versions.

NVD CVE-2026-66703Patchstack advisory

critical 9.8 CVE-2026-57813 · published 2026-07-13

Privilege escalation in MailOptin (1.2.77.3 and older)

Affected
1.2.77.3 and older
Fixed in
1.2.78.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in properfraction MailOptin mailoptin allows Privilege Escalation.This issue affects MailOptin: from n/a through <= 1.2.77.3.

NVD CVE-2026-57813Patchstack advisory

medium 5.9 CVE-2025-58596 · published 2025-09-03

Stored cross-site scripting (XSS) in MailOptin (1.2.75.0 and older)

Affected
1.2.75.0 and older
Fixed in
1.2.75.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in properfraction MailOptin mailoptin allows Stored XSS.This issue affects MailOptin: from n/a through <= 1.2.75.0.

NVD CVE-2025-58596Patchstack advisory

medium 5.4 CVE-2024-8628 · published 2024-09-24

Stored cross-site scripting (XSS) in MailOptin (1.2.70.3 and older)

Affected
1.2.70.3 and older
Fixed in
1.2.70.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Popup, Optin Form & Email Newsletters for Mailchimp, HubSpot, AWeber – MailOptin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'post-meta' shortcode in all versions up to, and including, 1.2.70.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8628Wordfence advisoryCode change (fix)

medium 4.8 CVE-2023-23980 · published 2023-04-06

Stored cross-site scripting (XSS) in MailOptin (1.2.54.0 and older)

Affected
1.2.54.0 and older
Fixed in
1.2.54.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in MailOptin Popup Builder Team MailOptin plugin <= 1.2.54.0 versions.

NVD CVE-2023-23980Patchstack advisory

medium 5.3 CVE-2022-36340 · published 2022-09-23

Missing authorization check in MailOptin (1.2.49.0 and older)

Affected
1.2.49.0 and older
Fixed in
1.2.50.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauthenticated Optin Campaign Cache Deletion vulnerability in MailOptin plugin <= 1.2.49.0 at WordPress.

NVD CVE-2022-36340Patchstack advisoryplugins.svn.wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MailOptin vulnerability status badge
<a href="https://laskyr.com/plugins/mailoptin"><img src="https://laskyr.com/plugins/mailoptin/badge.svg" alt="MailOptin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit