Plugins · mailmunch · data as of 2026-11-04
Is MailMunch safe? Known vulnerabilities and latest version
- Latest version
- 3.3.3
- Last updated
- 2026-10-23
- Active installs
- 5,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
The best free plugin to get more email subscribers. Beautiful opt-in forms that integrate with MailChimp, Constant Contact, AWeber, Campaign Monitor a … — by mailmunch
What to do
- Update to the latest version (3.3.3). Anything older than 3.2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mailmunch --field=version shows what you run; wp plugin update mailmunch updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-81783 · published 2026-09-10
Authentication bypass in MailMunch (3.2.5 and older)
- Affected
- 3.2.5 and older
- Fixed in
- 3.2.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Authentication in MailMunch – Grow your Email List <= 3.2.5 versions.
medium 6.1 CVE-2024-8735 · published 2024-11-22
Reflected cross-site scripting (XSS) in MailMunch (3.1.8 and older)
- Affected
- 3.1.8 and older
- Fixed in
- 3.1.9 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MailMunch – Grow your Email List plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.1.8. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-8735Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2024-31349 · published 2024-04-07
Stored cross-site scripting (XSS) in MailMunch (3.1.6 and older)
- Affected
- 3.1.6 and older
- Fixed in
- 3.1.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MailMunch MailMunch – Grow your Email List allows Stored XSS.This issue affects MailMunch – Grow your Email List: from n/a through 3.1.6.
high 8.8 CVE-2023-41852 · published 2023-10-10
Cross-site request forgery (CSRF) in MailMunch (3.1.2 and older)
- Affected
- 3.1.2 and older
- Fixed in
- 3.1.4 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in MailMunch MailMunch – Grow your Email List plugin <= 3.1.2 versions.
Recent activity
- 2026-10-23 — latest release on wordpress.org (3.3.3).
- 2026-09-10 — Authentication bypass disclosed (CVE-2026-81783), fixed in 3.2.6.
- 2024-11-22 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-8735), fixed in 3.1.9.
- 2024-04-07 — Stored cross-site scripting (XSS) disclosed (CVE-2024-31349), fixed in 3.1.7.
Get an email when MailMunch has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MailMunch (mailmunch) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by mailmunch (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Authentication bypass (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mailmunch (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mailmunch"><img src="https://laskyr.com/plugins/mailmunch/badge.svg" alt="MailMunch vulnerability status"></a>