Plugins · mailin · data as of 2026-11-04
Is Brevo safe? Known vulnerabilities and latest version
- Latest version
- 3.3.5
- Last updated
- 2026-06-24
- Active installs
- 100,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 5.6+
Turn your WordPress site into a marketing powerhouse. Grow your audience, boost engagement, and drive more sales with Brevo. — by Brevo
What to do
- Update to the latest version (3.3.5). Anything older than 3.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mailin --field=version shows what you run; wp plugin update mailin updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-15297 · published 2026-07-10
Reflected cross-site scripting (XSS) in Brevo (3.1.77 and older)
- Affected
- 3.1.77 and older
- Fixed in
- 3.1.78 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Newsletter, SMTP, Email marketing and Subscribe forms by Brevo (formely Sendinblue) plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the page parameter in all versions up to, and including, 3.1.77 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2026-15297Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-14799 · published 2026-02-18
Security issue in Brevo (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Brevo - Email, SMS, Web Push, Chat, and more. plugin for WordPress is vulnerable to authorization bypass due to type juggling in all versions up to, and including, 3.3.0. This is due to the use of loose comparison (==) instead of strict comparison (===) when validating the installation ID in the `/wp-json/mailin/v1/mailin_disconnect` REST API endpoint. This makes it possible for unauthenticated attackers to disconnect the Brevo integration, delete the API key, remove all subscription forms, and reset plugin settings by sending a boolean `true` value for the `id` parameter, which bypasses the authorization check through PHP type juggling.
NVD CVE-2025-14799Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2024-8477 · published 2024-10-10
Cross-site request forgery (CSRF) in Brevo (3.1.87 and older)
- Affected
- 3.1.87 and older
- Fixed in
- 3.1.88 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Newsletter, SMTP, Email marketing and Subscribe forms by Brevo (formely Sendinblue) plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.1.87. This is due to missing or incorrect nonce validation on the Init() function. This makes it possible for unauthenticated attackers to log out of a Brevo connection via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
high 8.8 CVE-2024-43287 · published 2024-08-26
Cross-site request forgery (CSRF) in Brevo (3.1.82 and older)
- Affected
- 3.1.82 and older
- Fixed in
- 3.1.83
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Brevo Newsletter, SMTP, Email marketing and Subscribe forms by Sendinblue.This issue affects Newsletter, SMTP, Email marketing and Subscribe forms by Sendinblue: from n/a through 3.1.82.
medium 6.1 CVE-2024-35668 · published 2024-06-04
Reflected cross-site scripting (XSS) in Brevo (3.1.77 and older)
- Affected
- 3.1.77 and older
- Fixed in
- 3.1.78
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Brevo Newsletter, SMTP, Email marketing and Subscribe forms by Sendinblue allows Reflected XSS.This issue affects Newsletter, SMTP, Email marketing and Subscribe forms by Sendinblue: from n/a through 3.1.77.
Recent activity
- 2026-06-24 — latest release on wordpress.org (3.3.5).
- 2026-07-10 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-15297), fixed in 3.1.78.
- 2026-02-18 — Security issue disclosed (CVE-2025-14799), fixed in 3.3.1.
- 2024-10-10 — Cross-site request forgery (CSRF) disclosed (CVE-2024-8477), fixed in 3.1.88.
Get an email when Brevo has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Brevo (mailin) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Brevo (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mailin (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mailin"><img src="https://laskyr.com/plugins/mailin/badge.svg" alt="Brevo vulnerability status"></a>