Skip to content
Laskyr

Plugins · mailgun-subscriptions · data as of 2026-11-04

Is Mailgun Subscriptions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.3)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3.3 or newer fixes all of them that state a fix.

Latest version
1.3.3
Last updated
2025-12-07
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

Add a Mailgun subscription form to your WordPress site. Your visitors can use the form to subscribe to your lists using the Mailgun API. — by Jonathan Brinley

What to do

  1. Update to the latest version (1.3.3). Anything older than 1.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mailgun-subscriptions --field=version shows what you run; wp plugin update mailgun-subscriptions updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-11876 · published 2025-12-12

Stored cross-site scripting (XSS) in Mailgun Subscriptions (1.3.1 and older)

Affected
1.3.1 and older
Fixed in
1.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Mailgun Subscriptions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'mailgun_subscription_form' shortcode in all versions up to, and including, 1.3.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-11876Wordfence advisoryCode change (fix)github.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Mailgun Subscriptions vulnerability status badge
<a href="https://laskyr.com/plugins/mailgun-subscriptions"><img src="https://laskyr.com/plugins/mailgun-subscriptions/badge.svg" alt="Mailgun Subscriptions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit