Skip to content
Laskyr

Plugins · mailgun · data as of 2026-11-04

Is Mailgun for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.3)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.1 or newer fixes all of them that state a fix.

Latest version
2.2.3
Last updated
2026-09-25
Active installs
80,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Easily send email from your WordPress site through Mailgun using the HTTP API or SMTP. — by Mailgun

What to do

  1. Update to the latest version (2.2.3). Anything older than 2.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mailgun --field=version shows what you run; wp plugin update mailgun updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-78003 · published 2026-08-22

Path traversal / file read in Mailgun for WordPress (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.2.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Mailgun for WordPress plugin for WordPress is vulnerable to Server-Side Request Forgery (SSRF) via path traversal in versions up to and including 2.2.0. This is due to insufficient input validation in the add_list() function, which accepts user-controlled array keys from $_POST['addresses'], passes them through sanitize_text_field(). This makes it possible for unauthenticated attackers to make authenticated POST requests to any Mailgun API endpoint using the WordPress site's API key, including creating inbound email-forwarding routes that can intercept password reset emails, leading to administrator account takeover.

NVD CVE-2026-78003Wordfence advisoryPlugin source

medium 6.5 CVE-2026-14834 · published 2026-07-31

Missing authorization check in Mailgun for WordPress (older than 2.2.1)

Affected
older than 2.2.1
Fixed in
2.2.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Mailgun for WordPress plugin before 2.2.1 does not perform any capability or nonce check on an unauthenticated AJAX action that adds subscribers to the site owner's configured email service mailing lists, allowing unauthenticated attackers to enrol arbitrary email addresses into those lists using the owner's stored API credentials.

NVD CVE-2026-14834WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Mailgun for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/mailgun"><img src="https://laskyr.com/plugins/mailgun/badge.svg" alt="Mailgun for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit