Skip to content
Laskyr

Plugins · mailerpress · data as of 2026-11-04

Is MailerPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2)

As of 2026-11-04. 5 issues are on record for older versions; version 2.0.5 or newer fixes all of them that state a fix.

Latest version
2.2
Last updated
2026-10-26
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Write, send and track newsletters from WordPress. Block-based email editor, unlimited contacts and lists, sending through your host or SMTP. — by MailerPress Team

What to do

  1. Update to the latest version (2.2). Anything older than 2.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mailerpress --field=version shows what you run; wp plugin update mailerpress updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-18436 · published 2026-07-31

Missing authorization check in MailerPress (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.5.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailPress plugin for WordPress is vulnerable to unauthorized access in versions up to, and including, 1.5.0 via the campaign revision-restore REST endpoint (POST /wp-json/mailpress/v1/campaign/<id>/restore-revision/<revision_id>). The route in the vulnerable range was registered without a permissionCallback, allowing the restoreRevision() handler to run for unauthenticated requests and overwrite a campaign's content_html with any prior revision. This makes it possible for unauthenticated attackers to modify campaign content by restoring an arbitrary revision.

NVD CVE-2026-18436Wordfence advisoryPlugin source

medium 5.3 CVE-2026-18437 · published 2026-07-31

Missing authorization check in MailerPress (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.5.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailerPress – Newsletter, email marketing & AI automation plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the `mailerpress/v1/contact` endpoint in all versions up to, and including, 1.5.0. This makes it possible for unauthenticated attackers to update contact details.

NVD CVE-2026-18437Wordfence advisoryPlugin source

high 8.8 CVE-2026-57410 · published 2026-07-13

Privilege escalation in MailerPress (2.0.2 and older)

Affected
2.0.2 and older
Fixed in
2.0.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in MailerPress Team MailerPress mailerpress allows Privilege Escalation.This issue affects MailerPress: from n/a through <= 2.0.2.

NVD CVE-2026-57410Patchstack advisory

medium 6.4 CVE-2026-8599 · published 2026-06-09

Stored cross-site scripting (XSS) in MailerPress (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.0.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailerPress – Email Marketing, Newsletter, Email Automation & WooCommerce Emails plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Campaign HTML Content Field in all versions up to, and including, 2.0.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The public-facing campaign preview endpoint (/mp-email/{id}-slug/) is not affected by this vulnerability, as it applies a Content-Security-Policy header blocking all inline scripts; exploitation is limited to the admin dashboard preview.

NVD CVE-2026-8599Wordfence advisoryPlugin source

medium 6.4 CVE-2026-32353 · published 2026-03-13

Server-side request forgery (SSRF) in MailerPress (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.5.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in MailerPress Team MailerPress mailerpress allows Server Side Request Forgery.This issue affects MailerPress: from n/a through <= 1.4.2.

NVD CVE-2026-32353Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MailerPress vulnerability status badge
<a href="https://laskyr.com/plugins/mailerpress"><img src="https://laskyr.com/plugins/mailerpress/badge.svg" alt="MailerPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit