Plugins · mailchimp-subscribe-sm · data as of 2026-11-04
Is MailChimp Subscribe Form, Optin Builder, PopUp… safe? Known vulnerabilities and latest version
- Latest version
- 4.3.4
- Last updated
- 2026-07-29
- Active installs
- 2,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.0+
MailChimp Subscribe Form allows you to create Beautiful Professional looking Subscribe Forms, Popups, bars & full page optins easily in less than … — by PluginOps
What to do
- Update to the latest version (4.3.4). Anything older than 4.3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mailchimp-subscribe-sm --field=version shows what you run; wp plugin update mailchimp-subscribe-sm updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-27536 · published 2026-08-13
Cross-site scripting (XSS) in MailChimp Subscribe Form, Optin Builder, PopUp… (4.3.3 and older)
- Affected
- 4.3.3 and older
- Fixed in
- 4.3.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in MailChimp Subscribe Forms <= 4.3.3 versions.
high 7.2 CVE-2026-15052 · published 2026-08-01
Stored cross-site scripting (XSS) in MailChimp Subscribe Form, Optin Builder, PopUp… (4.3.3 and older)
- Affected
- 4.3.3 and older
- Fixed in
- 4.3.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MailChimp Subscribe Form, Optin Builder, PopUp Builder, Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Form Field Values in all versions up to, and including, 4.3.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15052Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-22727 · published 2025-01-21
Stored cross-site scripting (XSS) in MailChimp Subscribe Form, Optin Builder, PopUp… (4.1 and older)
- Affected
- 4.1 and older
- Fixed in
- 4.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PluginOps MailChimp Subscribe Forms mailchimp-subscribe-sm allows Stored XSS.This issue affects MailChimp Subscribe Forms : from n/a through <= 4.1.
medium 5.9 CVE-2024-43211 · published 2024-11-01
Stored cross-site scripting (XSS) in MailChimp Subscribe Form, Optin Builder, PopUp… (4.0.9.9 and older)
- Affected
- 4.0.9.9 and older
- Fixed in
- 4.1 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PluginOps MailChimp Subscribe Forms allows Stored XSS.This issue affects MailChimp Subscribe Forms : from n/a through 4.0.9.9.
medium 6.1 CVE-2023-32517 · published 2023-12-29
Open redirect in MailChimp Subscribe Form, Optin Builder, PopUp… (4.0.9.3 and older)
- Affected
- 4.0.9.3 and older
- Fixed in
- 4.0.9.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in PluginOps MailChimp Subscribe Form, Optin Builder, PopUp Builder, Form Builder.This issue affects MailChimp Subscribe Form, Optin Builder, PopUp Builder, Form Builder: from n/a through 4.0.9.3.
medium 4.8 CVE-2023-33328 · published 2023-05-28
Stored cross-site scripting (XSS) in MailChimp Subscribe Form, Optin Builder, PopUp… (4.0.9.1 and older)
- Affected
- 4.0.9.1 and older
- Fixed in
- 4.0.9.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in PluginOps MailChimp Subscribe Form plugin <= 4.0.9.1 versions.
Recent activity
- 2026-07-29 — latest release on wordpress.org (4.3.4).
- 2026-08-13 — Cross-site scripting (XSS) disclosed (CVE-2026-27536), fixed in 4.3.4.
- 2026-08-01 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15052), fixed in 4.3.4.
- 2025-01-21 — Stored cross-site scripting (XSS) disclosed (CVE-2025-22727), fixed in 4.2.
Get an email when MailChimp Subscribe Form, Optin Builder, PopUp… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MailChimp Subscribe Form, Optin Builder, PopUp… (mailchimp-subscribe-sm) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by PluginOps (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (5) · Open redirect (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mailchimp-subscribe-sm (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mailchimp-subscribe-sm"><img src="https://laskyr.com/plugins/mailchimp-subscribe-sm/badge.svg" alt="MailChimp Subscribe Form, Optin Builder, PopUp… vulnerability status"></a>