Skip to content
Laskyr

Plugins · mailchimp-for-woocommerce · data as of 2026-11-04

Is Mailchimp for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.3)

As of 2026-11-04. 6 issues are on record for older versions; version 6.3 or newer fixes all of them that state a fix.

Latest version
6.3
Last updated
2026-09-23
Active installs
200,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Connect your store to your Mailchimp audience to track sales, create targeted emails, send abandoned cart emails, and more. — by Mailchimp

What to do

  1. Update to the latest version (6.3). Anything older than 6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mailchimp-for-woocommerce --field=version shows what you run; wp plugin update mailchimp-for-woocommerce updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-92437 · published 2026-10-03

Missing authorization check in Mailchimp for WooCommerce (older than 6.3)

Affected
older than 6.3
Fixed in
6.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Mailchimp for WooCommerce WordPress plugin before 6.3 does not require authentication, a nonce or an ownership check before it acts on a customer's abandoned-cart record identified from request-supplied data, allowing an unauthenticated attacker to modify or delete another customer's stored cart.

NVD CVE-2026-92437WPScan advisory

medium 5.3 CVE-2026-92436 · published 2026-09-27

Missing authorization check in Mailchimp for WooCommerce (older than 6.3)

Affected
older than 6.3
Fixed in
6.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Mailchimp for WooCommerce WordPress plugin before 6.3 does not require authentication or verify ownership before loading a saved cart from a request-supplied identifier that is derived from a customer's email address, allowing an unauthenticated attacker who knows a customer's email address to confirm that the customer shops at the store and to read that customer's saved cart contents.

NVD CVE-2026-92436WPScan advisory

medium 5.3 CVE-2026-92435 · published 2026-09-19

Missing authorization check in Mailchimp for WooCommerce (older than 6.1.1)

Affected
older than 6.1.1
Fixed in
6.1.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Mailchimp for WooCommerce WordPress plugin before 6.1.1 does not verify that the requesting user holds the required capability in the permission callback for several of its REST API routes, allowing unauthenticated users to reach administrator-oriented endpoints and trigger a persistent state change.

NVD CVE-2026-92435WPScan advisory

high 7.6 CVE-2026-73346 · published 2026-08-13

SQL injection in Mailchimp for WooCommerce (older than 6.2)

Affected
older than 6.2
Fixed in
6.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Administrator SQL Injection in MailChimp For WooCommerce < 6.2 versions.

NVD CVE-2026-73346Patchstack advisory

medium 4.3 CVE-2022-2267 · published 2022-08-29

Server-side request forgery (SSRF) in Mailchimp for WooCommerce (older than 2.7.1)

Affected
older than 2.7.1
Fixed in
2.7.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
NVD analysis · score by NVD
Details from the advisory

The Mailchimp for WooCommerce WordPress plugin before 2.7.1 has an AJAX action that allows any logged in users (such as subscriber) to perform a POST request on behalf of the server to the internal network/LAN, the body of the request is also appended to the response so it can be used to scan private network for example

NVD CVE-2022-2267WPScan advisory

low 2.7 CVE-2022-2556 · published 2022-08-29

Server-side request forgery (SSRF) in Mailchimp for WooCommerce (older than 2.7.2)

Affected
older than 2.7.2
Fixed in
2.7.2
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

The Mailchimp for WooCommerce WordPress plugin before 2.7.2 has an AJAX action that allows high privilege users to perform a POST request on behalf of the server to the internal network/LAN, the body of the request is also appended to the response so it can be used to scan private network for example

NVD CVE-2022-2556WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Mailchimp for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/mailchimp-for-woocommerce"><img src="https://laskyr.com/plugins/mailchimp-for-woocommerce/badge.svg" alt="Mailchimp for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit