Skip to content
Laskyr

Plugins · mailarchiver · data as of 2026-11-04

Is MailArchiver safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.7.0)

As of 2026-11-04. 3 issues are on record for older versions; version 4.5.1 or newer fixes all of them that state a fix.

Latest version
4.7.0
Last updated
2026-08-18
Active installs
100+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Automatically archive all emails sent from your site. Store them in your WordPress database or send them to external services. — by Pierre Lannoy

What to do

  1. Update to the latest version (4.7.0). Anything older than 4.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mailarchiver --field=version shows what you run; wp plugin update mailarchiver updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.8 CVE-2026-2721 · published 2026-03-07

Stored cross-site scripting (XSS) in MailArchiver (4.4.0 and older)

Affected
4.4.0 and older
Fixed in
4.5.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailArchiver plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 4.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-2721Wordfence advisoryCode change (fix)github.comPlugin source

medium 4.9 CVE-2026-2831 · published 2026-02-27

SQL injection in MailArchiver (4.5.0 and older)

Affected
4.5.0 and older
Fixed in
4.5.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailArchiver plugin for WordPress is vulnerable to SQL Injection via the ‘logid’ parameter in all versions up to, and including, 4.5.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-2831Wordfence advisoryPlugin source

medium 6.1 CVE-2023-3136 · published 2023-08-30

Stored cross-site scripting (XSS) in MailArchiver (2.10.1 and older)

Affected
2.10.1 and older
Fixed in
2.11.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MailArchiver plugin for WordPress is vulnerable to Stored Cross-Site Scripting via an email subject in versions up to, and including, 2.10.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-3136Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MailArchiver vulnerability status badge
<a href="https://laskyr.com/plugins/mailarchiver"><img src="https://laskyr.com/plugins/mailarchiver/badge.svg" alt="MailArchiver vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit