Skip to content
Laskyr

Plugins · magical-products-display · data as of 2026-11-04

Is Magical Shop Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.37 or newer fixes all of them that state a fix.

Latest version
2.1.1
Last updated
2026-10-18
Active installs
3,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The complete WooCommerce Shop Builder for Elementor. Build custom single product pages, cart, checkout, my account & shop archives with 60+ widgets. — by Noor Alam

What to do

  1. Update to the latest version (2.1.1). Anything older than 1.1.37 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get magical-products-display --field=version shows what you run; wp plugin update magical-products-display updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-12964 · published 2025-11-21

Stored cross-site scripting (XSS) in Magical Shop Builder (1.1.29 and older)

Affected
1.1.29 and older
Fixed in
1.1.37 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Magical Products Display plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'mpdpr_title_tag' and 'mpdpr_subtitle_tag' parameters in the MPD Pricing Table widget in all versions up to, and including, 1.1.29 due to insufficient input sanitization and output escaping on user-supplied HTML tag names. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-12964Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Magical Shop Builder vulnerability status badge
<a href="https://laskyr.com/plugins/magical-products-display"><img src="https://laskyr.com/plugins/magical-products-display/badge.svg" alt="Magical Shop Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit