Plugins · magic-import-document-extractor · data as of 2026-11-04
Is Magic Import Document Extractor safe? Known vulnerabilities and latest version
- Latest version
- 1.0.6
- Last updated
- 2026-02-03
- Active installs
- fewer than 10
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.9.11 · PHP 7.4+
AI-powered document extraction for WordPress forms. Supports PDF, Word, images in 10+ languages. 10 free uploads/month. — by magicimport
What to do
- There is no fixed version yet. If you can live without Magic Import Document Extractor for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get magic-import-document-extractor --field=version shows what you run; wp plugin update magic-import-document-extractor updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-15507 · published 2026-02-04
Missing authorization check in Magic Import Document Extractor (1.0.5 and older)
- Affected
- 1.0.5 and older
- Fixed in
- 1.0.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Magic Import Document Extractor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ajax_sync_usage() function in all versions up to, and including, 1.0.5. This makes it possible for unauthenticated attackers to modify the plugin's license status and credit balance.
NVD CVE-2025-15507Wordfence advisoryCode change (fix)Plugin source
medium 5.3 affects latest 1.0.6 CVE-2025-15508 · published 2026-02-04
Information disclosure in Magic Import Document Extractor (1.0.6 and older)
- Affected
- 1.0.6 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Magic Import Document Extractor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.0.4 via the get_frontend_settings() function. This makes it possible for unauthenticated attackers to extract the site's magicimport.ai license key from the page source on any page containing the plugin's shortcode.
Recent activity
- 2026-02-03 — latest release on wordpress.org (1.0.6).
- 2026-02-04 — Missing authorization check disclosed (CVE-2025-15507), fixed in 1.0.6.
- 2026-02-04 — Information disclosure disclosed (CVE-2025-15508), no fix listed yet.
Get an email when Magic Import Document Extractor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Magic Import Document Extractor (magic-import-document-extractor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/magic-import-document-extractor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/magic-import-document-extractor"><img src="https://laskyr.com/plugins/magic-import-document-extractor/badge.svg" alt="Magic Import Document Extractor vulnerability status"></a>