Skip to content
Laskyr

Plugins · magic-conversation-for-gravity-forms · data as of 2026-11-04

Is Magic Conversation For Gravity Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.102)

As of 2026-11-04. 1 issue is on record for older versions.

Latest version
3.0.102
Last updated
2026-10-01
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

Magic Conversation For Gravity Forms is a WordPress conversational form plugin that let's you convert a Gravity Form into a conversational form. — by magicplugins

What to do

  1. Update to the latest version (3.0.102). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get magic-conversation-for-gravity-forms --field=version shows what you run; wp plugin update magic-conversation-for-gravity-forms updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1396 · published 2026-04-08

Stored cross-site scripting (XSS) in Magic Conversation For Gravity Forms (3.0.97 and older)

Affected
3.0.97 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Magic Conversation For Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'magic-conversation' shortcode in all versions up to, and including, 3.0.97 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1396Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Magic Conversation For Gravity Forms vulnerability status badge
<a href="https://laskyr.com/plugins/magic-conversation-for-gravity-forms"><img src="https://laskyr.com/plugins/magic-conversation-for-gravity-forms/badge.svg" alt="Magic Conversation For Gravity Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit