Plugins · lws-optimize · data as of 2026-11-04
Is LWS Optimize safe? Known vulnerabilities and latest version
- Latest version
- 4.1.7
- Last updated
- 2026-10-14
- Active installs
- 20,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
All-in-one speed optimization: caching, WebP/AVIF, Critical CSS, lazy loading, CDN, and more. Instantly boost Core Web Vitals and site speed! — by Aurélien LWS
What to do
- Update to the latest version (4.1.7). Anything older than 4.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get lws-optimize --field=version shows what you run; wp plugin update lws-optimize updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-16032 · published 2026-08-09
Cross-site scripting (XSS) in LWS Optimize (older than 4.1.2)
- Affected
- older than 4.1.2
- Fixed in
- 4.1.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The LWS Optimize WordPress plugin before 4.1.2 does not properly escape a value submitted through an unauthenticated analytics endpoint before storing it and rendering it in an administrative dashboard, allowing unauthenticated attackers to inject arbitrary web scripts that execute when an administrator views the affected dashboard page.
medium 4.3 CVE-2026-16042 · published 2026-08-02
Missing authorization check in LWS Optimize (older than 3.4)
- Affected
- older than 3.4
- Fixed in
- 3.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The LWS Optimize WordPress plugin before 3.4 does not perform a capability check on its cache-clearing actions, allowing any authenticated user, including Subscribers, to flush the site's caches and force repeated cache rebuilds.
medium 4.9 CVE-2026-12089 · published 2026-06-13
Path traversal / file read in LWS Optimize (3.3.19 and older)
- Affected
- 3.3.19 and older
- Fixed in
- 3.3.20 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The LWS Optimize – All-in-One Speed Booster & Cache Tools plugin for WordPress is vulnerable to Arbitrary File Read in versions up to, and including, 3.3.19. This is due to the combine_current_css() function trusting <link rel="stylesheet" href="..."> values harvested from page HTML and converting same-site URLs to absolute filesystem paths before reading them with file_get_contents()/Minify\CSS::add(), without enforcing that the resolved path stay within ABSPATH or have a .css extension. This makes it possible for authenticated attackers, with Editor-level access and above, to read arbitrary files.
medium 4.3 CVE-2024-30541 · published 2024-03-31
Cross-site request forgery (CSRF) in LWS Optimize (1.9.1 and older)
- Affected
- 1.9.1 and older
- Fixed in
- 2.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in LWS LWS Optimize.This issue affects LWS Optimize: from n/a through 1.9.1.
Recent activity
- 2026-10-14 — latest release on wordpress.org (4.1.7).
- 2026-08-09 — Cross-site scripting (XSS) disclosed (CVE-2026-16032), fixed in 4.1.2.
- 2026-08-02 — Missing authorization check disclosed (CVE-2026-16042), fixed in 3.4.
- 2026-06-13 — Path traversal / file read disclosed (CVE-2026-12089), fixed in 3.3.20.
Get an email when LWS Optimize has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for LWS Optimize (lws-optimize) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Path traversal and file read (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/lws-optimize (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/lws-optimize"><img src="https://laskyr.com/plugins/lws-optimize/badge.svg" alt="LWS Optimize vulnerability status"></a>