Plugins · lupsonline-link-netwerk · data as of 2026-11-04
Is SEO Flow by LupsOnline safe? Known vulnerabilities and latest version
- Latest version
- 3.0.3
- Last updated
- 2026-08-31
- Active installs
- 200+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.7.11 · PHP 5.2.4+
High performance tool for linkbuilders to place and manage partner links and blogs on all websites on one central platform — by Michael Lups
What to do
- Update to the latest version (3.0.3). Anything older than 3.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get lupsonline-link-netwerk --field=version shows what you run; wp plugin update lupsonline-link-netwerk updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2026-78362 · published 2026-09-05
Privilege escalation in SEO Flow by LupsOnline (3.0.0 up to (not including) 3.0.3)
- Affected
- 3.0.0 up to (not including) 3.0.3
- Fixed in
- 3.0.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The SEO Flow by LupsOnline WordPress plugin before 3.0.3 does not correctly validate the credential supplied with its API requests, allowing unauthenticated users to be served as the administrator who configured the SEO Flow by LupsOnline WordPress plugin before 3.0.3 and take over the site. Exploitation requires the SEO Flow by LupsOnline WordPress plugin before 3.0.3 to have been configured, which is its normal operating state.
high 7.5 CVE-2025-15285 · published 2026-02-04
Missing authorization check in SEO Flow by LupsOnline (2.2.1 and older)
- Affected
- 2.2.1 and older
- Fixed in
- 3.0.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SEO Flow by LupsOnline plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the checkBlogAuthentication() and checkCategoryAuthentication() functions in all versions up to, and including, 2.2.1. These authorization functions only implement basic API key authentication but fail to implement WordPress capability checks. This makes it possible for unauthenticated attackers to create, modify, and delete blog posts and categories.
NVD CVE-2025-15285Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2025-48146 · published 2025-05-16
Cross-site request forgery (CSRF) in SEO Flow by LupsOnline (2.2.1 and older)
- Affected
- 2.2.1 and older
- Fixed in
- 3.0.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Michael Lups SEO Flow by LupsOnline lupsonline-link-netwerk allows Stored XSS.This issue affects SEO Flow by LupsOnline: from n/a through <= 2.2.1.
Recent activity
- 2026-08-31 — latest release on wordpress.org (3.0.3).
- 2026-09-05 — Privilege escalation disclosed (CVE-2026-78362), fixed in 3.0.3.
- 2026-02-04 — Missing authorization check disclosed (CVE-2025-15285), fixed in 3.0.0.
- 2025-05-16 — Cross-site request forgery (CSRF) disclosed (CVE-2025-48146), fixed in 3.0.0.
Get an email when SEO Flow by LupsOnline has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SEO Flow by LupsOnline (lupsonline-link-netwerk) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (1) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/lupsonline-link-netwerk (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/lupsonline-link-netwerk"><img src="https://laskyr.com/plugins/lupsonline-link-netwerk/badge.svg" alt="SEO Flow by LupsOnline vulnerability status"></a>