Skip to content
Laskyr

Plugins · ltl-freight-quotes-rl-edition · data as of 2026-11-04

Is LTL Freight Quotes safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.21)

As of 2026-11-04. 2 issues are on record for older versions; version 3.3.14 or newer fixes all of them that state a fix.

Latest version
3.3.21
Last updated
2026-10-20
Active installs
10+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Real-time LTL freight quotes from R+L carriers. Fifteen day free trial. — by enituretechnology

What to do

  1. Update to the latest version (3.3.21). Anything older than 3.3.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ltl-freight-quotes-rl-edition --field=version shows what you run; wp plugin update ltl-freight-quotes-rl-edition updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-3646 · published 2026-04-08

Missing authorization check in LTL Freight Quotes (3.3.13 and older)

Affected
3.3.13 and older
Fixed in
3.3.14 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The LTL Freight Quotes – R+L Carriers Edition plugin for WordPress is vulnerable to Missing Authorization via the plugin's webhook handler in all versions up to, and including, 3.3.13. This is due to missing authentication, authorization, and nonce verification on a standalone PHP file that directly processes GET parameters and updates WordPress options. This makes it possible for unauthenticated attackers to modify the plugin's subscription plan settings, effectively downgrading the store from a paid plan to the Trial Plan, changing the store type, and manipulating subscription expiration dates, potentially disabling premium features such as Dropship and Hazardous Material handling.

NVD CVE-2026-3646Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2024-13481 · published 2025-02-19

SQL injection in LTL Freight Quotes (3.3.4 and older)

Affected
3.3.4 and older
Fixed in
3.3.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The LTL Freight Quotes – R+L Carriers Edition plugin for WordPress is vulnerable to SQL Injection via the 'edit_id' and 'dropship_edit_id' parameters in all versions up to, and including, 3.3.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-13481Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
LTL Freight Quotes vulnerability status badge
<a href="https://laskyr.com/plugins/ltl-freight-quotes-rl-edition"><img src="https://laskyr.com/plugins/ltl-freight-quotes-rl-edition/badge.svg" alt="LTL Freight Quotes vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit