Skip to content
Laskyr

Plugins · lpagery · data as of 2026-11-04

Is Bulk Page Generator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.2)

As of 2026-11-04. 3 issues are on record for older versions; version 3.1.1 or newer fixes all of them that state a fix.

Latest version
3.1.2
Last updated
2026-10-16
Active installs
3,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Effortlessly mass generate unlimited SEO-optimized pages in bulk with LPagery. Boost traffic, save time, and grow your business in just 5 minutes! — by niklaslindemann

What to do

  1. Update to the latest version (3.1.2). Anything older than 3.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get lpagery --field=version shows what you run; wp plugin update lpagery updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-110019 · published 2026-10-16

Missing authorization check in Bulk Page Generator (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
3.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bulk Page Generator – LPagery plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.1.0 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to create, modify, and delete LPagery-managed WordPress pages and bulk page-generation processes that are otherwise restricted to administrators. On default fresh installations where Freemius has not been opted into, the AES-256-CBC key used to validate Bearer tokens collapses to the publicly known SHA-256 hash of an empty string, making the token entirely forgeable by any authenticated user.

NVD CVE-2026-110019Wordfence advisoryPlugin source

medium 6.4 CVE-2026-15404 · published 2026-07-23

Stored cross-site scripting (XSS) in Bulk Page Generator (2.5.7 and older)

Affected
2.5.7 and older
Fixed in
2.5.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Lpagery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via post titles in versions up to, and including, 2.5.7. This is due to insufficient input sanitization and output escaping in the lpagery_add_filter_text_template_post() function, which is hooked to admin_footer and echoes the raw post_title of the post referenced by the ?lpagery_template query parameter directly inside a JavaScript single-quoted string literal, without esc_js(), esc_html(), or any other encoding. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a higher-privileged user (such as an administrator) accesses an admin page with the ?lpagery_template=<post_id> parameter pointing at the attacker's post.

NVD CVE-2026-15404Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2026-22490 · published 2026-01-08

Missing authorization check in Bulk Page Generator (2.4.9 and older)

Affected
2.4.9 and older
Fixed in
2.4.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in niklaslindemann Bulk Landing Page Creator for WordPress LPagery lpagery allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Bulk Landing Page Creator for WordPress LPagery: from n/a through <= 2.4.9.

NVD CVE-2026-22490Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bulk Page Generator vulnerability status badge
<a href="https://laskyr.com/plugins/lpagery"><img src="https://laskyr.com/plugins/lpagery/badge.svg" alt="Bulk Page Generator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit