Skip to content
Laskyr

Plugins · lottiefiles · data as of 2026-11-04

Is LottieFiles safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.0 or newer fixes all of them that state a fix.

Latest version
3.1.0
Last updated
2026-01-19
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

LottieFiles for WordPress is the easiest way to add Lottie animations to your WordPress website using the Gutenberg editor. — by LottieFiles

What to do

  1. Update to the latest version (3.1.0). Anything older than 3.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get lottiefiles --field=version shows what you run; wp plugin update lottiefiles updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.3 CVE-2025-68043 · published 2026-02-20

Missing authorization check in LottieFiles (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
3.1.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in LottieFiles LottieFiles lottiefiles allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects LottieFiles: from n/a through <= 3.0.0.

NVD CVE-2025-68043Patchstack advisory

medium 5.3 CVE-2026-0717 · published 2026-01-14

Information disclosure in LottieFiles (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The LottieFiles – Lottie block for Gutenberg plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.0 via the `/wp-json/lottiefiles/v1/settings/` REST API endpoint. This makes it possible for unauthenticated attackers to retrieve the site owner's LottieFiles.com account credentials including their API access token and email address when the 'Share LottieFiles account with other WordPress users' option is enabled.

NVD CVE-2026-0717Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
LottieFiles vulnerability status badge
<a href="https://laskyr.com/plugins/lottiefiles"><img src="https://laskyr.com/plugins/lottiefiles/badge.svg" alt="LottieFiles vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit