Plugins · logo-slider-wp · data as of 2026-11-04
Is Logo Slider WP safe? Known vulnerabilities and latest version
- Latest version
- 6.1.1
- Last updated
- 2026-11-02
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Show client logos and WooCommerce brand logos in a responsive logo slider, carousel, grid or flexbox layout, with a Gutenberg block or shortcode. — by LogicHunt
What to do
- Update to the latest version (6.1.1). Anything older than 5.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get logo-slider-wp --field=version shows what you run; wp plugin update logo-slider-wp updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-13247 · published 2026-07-10
Stored cross-site scripting (XSS) in Logo Slider WP (5.5 and older)
- Affected
- 5.5 and older
- Fixed in
- 5.5.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Logo Slider – Logo Carousel, Client Logo Slider & Brand Showcase for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'lgx_tooltip_position' parameter in all versions up to, and including, 5.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-13247Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-0609 · published 2026-03-21
Stored cross-site scripting (XSS) in Logo Slider WP (4.9.0 and older)
- Affected
- 4.9.0 and older
- Fixed in
- 5.0.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Logo Slider – Logo Carousel, Logo Showcase & Client Logo Slider Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the image alt text in all versions up to, and including, 4.9.0 due to insufficient input sanitization and output escaping in the 'logo-slider' shortcode. This makes it possible for authenticated attackers, with author level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-0609Wordfence advisoryCode change (fix)Plugin source
medium 5.9 CVE-2026-24626 · published 2026-01-23
Stored cross-site scripting (XSS) in Logo Slider WP (5.1.1 and older)
- Affected
- 5.1.1 and older
- Fixed in
- 5.2.0 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LogicHunt Logo Slider logo-slider-wp allows Stored XSS.This issue affects Logo Slider: from n/a through <= 5.1.1.
Recent activity
- 2026-11-02 — latest release on wordpress.org (6.1.1).
- 2026-07-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-13247), fixed in 5.5.4.
- 2026-03-21 — Stored cross-site scripting (XSS) disclosed (CVE-2026-0609), fixed in 5.0.0.
- 2026-01-23 — Stored cross-site scripting (XSS) disclosed (CVE-2026-24626), fixed in 5.2.0.
Get an email when Logo Slider WP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Logo Slider WP (logo-slider-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/logo-slider-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/logo-slider-wp"><img src="https://laskyr.com/plugins/logo-slider-wp/badge.svg" alt="Logo Slider WP vulnerability status"></a>