Skip to content
Laskyr

Plugins · logo-showcase · data as of 2026-11-04

Is Logo Showcase safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.6)

As of 2026-11-04. 3 issues are on record for older versions; version 4.0.5 or newer fixes all of them that state a fix.

Latest version
4.0.6
Last updated
2026-10-29
Active installs
900+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Create beautiful logo showcases for clients, sponsors, partners, or brands using slider, grid, list, or ticker layouts — no coding required. — by Themepoints

What to do

  1. Update to the latest version (4.0.6). Anything older than 4.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get logo-showcase --field=version shows what you run; wp plugin update logo-showcase updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-105060 · published 2026-10-05

Stored cross-site scripting (XSS) in Logo Showcase (4.0.4 and older)

Affected
4.0.4 and older
Fixed in
4.0.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themepoints Logo Showcase logo-showcase allows Stored XSS.This issue affects Logo Showcase: from n/a through 4.0.4.

NVD CVE-2026-105060Patchstack advisory

medium 6.5 CVE-2025-58684 · published 2025-09-22

Stored cross-site scripting (XSS) in Logo Showcase (4.0.1 and older)

Affected
4.0.1 and older
Fixed in
4.0.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themepoints Logo Showcase logo-showcase allows Stored XSS.This issue affects Logo Showcase: from n/a through <= 4.0.1.

NVD CVE-2025-58684Patchstack advisory

medium 6.5 CVE-2025-47497 · published 2025-05-07

Cross-site scripting (XSS) in Logo Showcase (3.0.4 and older)

Affected
3.0.4 and older
Fixed in
3.0.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themepoints Logo Showcase logo-showcase allows DOM-Based XSS.This issue affects Logo Showcase: from n/a through <= 3.0.4.

NVD CVE-2025-47497Patchstack advisorylists.debian.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Logo Showcase vulnerability status badge
<a href="https://laskyr.com/plugins/logo-showcase"><img src="https://laskyr.com/plugins/logo-showcase/badge.svg" alt="Logo Showcase vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit