Plugins · loginizer · data as of 2026-11-01
Is Loginizer safe? Known vulnerabilities and latest version
- Latest version
- 2.1.3
- Last updated
- 2026-10-29
- Active installs
- 1+ million
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.5+
Loginizer is a WordPress security plugin which helps you fight against bruteforce attacks. — by Softaculous
What to do
- Update to the latest version (2.1.3). Anything older than 1.9.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get loginizer --field=version shows what you run; wp plugin update loginizer updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.1 CVE-2024-10097 · published 2024-11-05
Authentication bypass in Loginizer (1.9.2 and older)
- Affected
- 1.9.2 and older
- Fixed in
- 1.9.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Loginizer Security and Loginizer plugins for WordPress are vulnerable to authentication bypass in all versions up to, and including, 1.9.2. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email and the user does not have an already-existing account for the service returning the token.
NVD CVE-2024-10097Wordfence advisoryCode change (fix)loginizer.comPlugin source
medium 6.1 CVE-2023-2296 · published 2023-05-30
Reflected cross-site scripting (XSS) in Loginizer (1.7.8 up to (not including) 1.7.9)
- Affected
- 1.7.8 up to (not including) 1.7.9
- Fixed in
- 1.7.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Loginizer WordPress plugin before 1.7.9 does not escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
high 8.8 CVE-2022-45079 · published 2023-05-22
Cross-site request forgery (CSRF) in Loginizer (1.7.5 and older)
- Affected
- 1.7.5 and older
- Fixed in
- 1.7.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Softaculous Loginizer plugin <= 1.7.5 versions.
medium 6.1 CVE-2022-45084 · published 2023-04-24
Reflected cross-site scripting (XSS) in Loginizer (1.7.5 and older)
- Affected
- 1.7.5 and older
- Fixed in
- 1.7.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Softaculous Loginizer plugin <= 1.7.5 versions.
critical 9.8 CVE-2020-27615 · published 2020-10-21
Cross-site scripting (XSS) in Loginizer (older than 1.6.4)
- Affected
- older than 1.6.4
- Fixed in
- 1.6.4
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Loginizer plugin before 1.6.4 for WordPress allows SQL injection (with resultant XSS), related to loginizer_login_failed and lz_valid_ip.
NVD CVE-2020-27615WPScan advisoryCode change (fix)wpdeeply.comzdnet.com
medium 6.1 CVE-2018-11366 · published 2018-05-22
Stored cross-site scripting (XSS) in Loginizer (1.3.8 only, 1.3.9 only)
- Affected
- 1.3.8 only, 1.3.9 only
- Fixed in
- 1.4.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
init.php in the Loginizer plugin 1.3.8 through 1.3.9 for WordPress has Unauthenticated Stored Cross-Site Scripting (XSS) because logging is mishandled. This is fixed in 1.4.0.
NVD CVE-2018-11366Code change (fix)wordpress.orgblog.dewhurstsecurity.comwpvulndb.com
critical 9.8 CVE-2017-12650 · published 2017-08-07
SQL injection in Loginizer (1.3.5 and older)
- Affected
- 1.3.5 and older
- Fixed in
- 1.3.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
SQL Injection exists in the Loginizer plugin before 1.3.6 for WordPress via the X-Forwarded-For HTTP header.
high 8.8 CVE-2017-12651 · published 2017-08-07
Cross-site request forgery (CSRF) in Loginizer (1.3.5 and older)
- Affected
- 1.3.5 and older
- Fixed in
- 1.3.6 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
Cross Site Request Forgery (CSRF) exists in the Blacklist and Whitelist IP Wizard in init.php in the Loginizer plugin before 1.3.6 for WordPress because the HTTP Referer header is not checked.
Recent activity
- 2026-10-29 — latest release on wordpress.org (2.1.3).
- 2024-11-05 — Authentication bypass disclosed (CVE-2024-10097), fixed in 1.9.3.
- 2023-05-30 — Reflected cross-site scripting (XSS) disclosed (CVE-2023-2296), fixed in 1.7.9.
- 2023-05-22 — Cross-site request forgery (CSRF) disclosed (CVE-2022-45079), fixed in 1.7.6.
Get an email when Loginizer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Loginizer (loginizer) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/loginizer (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/loginizer"><img src="https://laskyr.com/plugins/loginizer/badge.svg" alt="Loginizer vulnerability status"></a>