Plugins · login-with-ajax · data as of 2026-11-04
Is Login With Ajax safe? Known vulnerabilities and latest version
- Latest version
- 4.5.1
- Last updated
- 2026-05-24
- Active installs
- 10,000+
- Known issues on record
- 4
- Unpatched in latest
- 2
- Tested up to WP
- 7.0.8 · PHP 5.2+
Add beautiful login forms with smooth AJAX login/registration effects, 2FA support, custom redrection options and many more login-related features! — by Marcus (aka @msykes)
What to do
- There is no fixed version yet. If you can live without Login With Ajax for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get login-with-ajax --field=version shows what you run; wp plugin update login-with-ajax updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 4.5.1 CVE-2026-82883 · published 2026-09-02
Reflected cross-site scripting (XSS) in Login With Ajax (4.5.1 and older)
- Affected
- 4.5.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Marcus Login With Ajax allows Reflected XSS. This issue affects Login With Ajax: from n/a through 4.5.1.
medium 6.5 affects latest 4.5.1 CVE-2026-66640 · published 2026-08-18
Cross-site scripting (XSS) in Login With Ajax (4.5.1 and older)
- Affected
- 4.5.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in Login With Ajax <= 4.5.1 versions.
medium 4.3 CVE-2023-49859 · published 2024-12-09
Missing authorization check in Login With Ajax (4.1 and older)
- Affected
- 4.1 and older
- Fixed in
- 4.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Marcus (aka @msykes) Login With Ajax login-with-ajax allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Login With Ajax: from n/a through <= 4.1.
medium 4.3 CVE-2024-30546 · published 2024-04-15
Cross-site request forgery (CSRF) in Login With Ajax (4.1 and older)
- Affected
- 4.1 and older
- Fixed in
- 4.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Pixelite Login With Ajax.This issue affects Login With Ajax: from n/a through 4.1.
Recent activity
- 2026-05-24 — latest release on wordpress.org (4.5.1).
- 2026-09-02 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-82883), no fix listed yet.
- 2026-08-18 — Cross-site scripting (XSS) disclosed (CVE-2026-66640), no fix listed yet.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-49859), fixed in 4.2.
Get an email when Login With Ajax has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Login With Ajax (login-with-ajax) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Marcus (aka @msykes) (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/login-with-ajax (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/login-with-ajax"><img src="https://laskyr.com/plugins/login-with-ajax/badge.svg" alt="Login With Ajax vulnerability status"></a>