Skip to content
Laskyr

Plugins · login-lockdown · data as of 2026-11-04

Is Login Lockdown & Protection safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.19)

As of 2026-11-04. 5 issues are on record for older versions; version 2.18 or newer fixes all of them that state a fix.

Latest version
2.19
Last updated
2026-10-06
Active installs
100,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2+

Protect, lockdown & secure login form by limiting login attempts from the same IP & banning IPs. — by WebFactory

What to do

  1. Update to the latest version (2.19). Anything older than 2.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get login-lockdown --field=version shows what you run; wp plugin update login-lockdown updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.8 CVE-2026-97308 · published 2026-10-06

Security issue in Login Lockdown & Protection (2.17 and older)

Affected
2.17 and older
Fixed in
2.18
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in Login Lockdown <= 2.17 versions.

NVD CVE-2026-97308Patchstack advisory

medium 5.3 CVE-2025-11707 · published 2025-12-13

Weak randomness in Login Lockdown & Protection (2.14 and older)

Affected
2.14 and older
Fixed in
2.15 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Login Lockdown & Protection plugin for WordPress is vulnerable to IP Block Bypass in all versions up to, and including, 2.14. This is due to $unblock_key key being insufficiently random allowing unauthenticated users, with access to an administrative user email, to generate valid unblock keys for their IP Address. This makes it possible for unauthenticated attackers to bypass blocks due to invalid login attempts.

NVD CVE-2025-11707Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-3766 · published 2025-05-07

Missing authorization check in Login Lockdown & Protection (2.11 and older)

Affected
2.11 and older
Fixed in
2.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Login Lockdown & Protection plugin for WordPress is vulnerable to unauthorized nonce access due to a missing capability check on the ajax_run_tool function in all versions up to, and including, 2.11. This makes it possible for authenticated attackers, with Subscriber-level access and above, to obtain a valid nonce that can be used to generate a global unlock key, which can in turn be used to add arbitrary IP address to the plugin allowlist. This can only by exploited on new installations where the site administrator hasn't visited the loginlockdown page yet.

NVD CVE-2025-3766Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-1340 · published 2024-02-29

Missing authorization check in Login Lockdown & Protection (2.08 and older)

Affected
2.08 and older
Fixed in
2.09 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Login Lockdown – Protect Login Form plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the generate_export_file function in all versions up to, and including, 2.08. This makes it possible for authenticated attackers, with subscriber access and higher, to export this plugin's settings that include whitelisted IP addresses as well as a global unlock key. With the global unlock key an attacker can add their IP address to the whitelist.

NVD CVE-2024-1340Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2023-50837 · published 2023-12-29

SQL injection in Login Lockdown & Protection (2.06 and older)

Affected
2.06 and older
Fixed in
2.07
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WebFactory Ltd Login Lockdown – Protect Login Form.This issue affects Login Lockdown – Protect Login Form: from n/a through 2.06.

NVD CVE-2023-50837Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Login Lockdown & Protection vulnerability status badge
<a href="https://laskyr.com/plugins/login-lockdown"><img src="https://laskyr.com/plugins/login-lockdown/badge.svg" alt="Login Lockdown & Protection vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit