Plugins · lockme-calendars-integration · data as of 2026-11-04
Is Lockme calendars integration safe? Known vulnerabilities and latest version
- Latest version
- 2.11.1
- Last updated
- 2026-04-13
- Active installs
- 10+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 8.4+
This plugin integrates popular booking systems with Lockme OAuth2 API. — by lustmored
What to do
- Update to the latest version (2.11.1). Anything older than 2.11.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get lockme-calendars-integration --field=version shows what you run; wp plugin update lockme-calendars-integration updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2026-3367 · published 2026-07-11
Stored cross-site scripting (XSS) in Lockme calendars integration (2.11.0 and older)
- Affected
- 2.11.0 and older
- Fixed in
- 2.11.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Lockme OAuth2 calendars integration plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'App ID' setting in all versions up to, and including, 2.11.0. This is due to insufficient input sanitization and output escaping. The register_setting() call on line 197 lacks a sanitize callback, allowing unsanitized data to be stored via update_option(). When the settings page is rendered, the stored value is echoed directly into an HTML input's value attribute without esc_attr() on line 212. This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary web scripts in the settings page that will execute whenever a user accesses the plugin settings page. Multiple fields are affected: App ID (client_id), App Secret (client_secret), Bookings ID prefix (id_prefix), and API domain (api_domain). This vulnerability is particularly impactful in WordPress multisite installations where administrators of individual sites should not be able to execute JavaScript affecting other users.
NVD CVE-2026-3367Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-04-13 — latest release on wordpress.org (2.11.1).
- 2026-07-11 — Stored cross-site scripting (XSS) disclosed (CVE-2026-3367), fixed in 2.11.1.
Get an email when Lockme calendars integration has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Lockme calendars integration (lockme-calendars-integration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/lockme-calendars-integration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/lockme-calendars-integration"><img src="https://laskyr.com/plugins/lockme-calendars-integration/badge.svg" alt="Lockme calendars integration vulnerability status"></a>