Plugins · locker-content · data as of 2026-11-04
Is Locker Content safe? Known vulnerabilities and latest version
- Latest version
- 1.0.2
- Last updated
- 2026-05-24
- Active installs
- fewer than 10
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Lock your content behind various engagement gates including password protection, agreement forms, and user-generated content. — by AppGlut
What to do
- Update to the latest version (1.0.2). Anything older than 1.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get locker-content --field=version shows what you run; wp plugin update locker-content updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-12525 · published 2025-11-25
Information disclosure in Locker Content (1.0.0 and older)
- Affected
- 1.0.0 and older
- Fixed in
- 1.0.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Locker Content plugin for WordPress is vulnerable to Sensitive Information Exposure in version 1.0.0 via the 'lockerco_submit_post' AJAX endpoint. This makes it possible for unauthenticated attackers to extract content from posts that has been protected by the plugin.
NVD CVE-2025-12525Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2026-05-24 — latest release on wordpress.org (1.0.2).
- 2025-11-25 — Information disclosure disclosed (CVE-2025-12525), fixed in 1.0.1.
Get an email when Locker Content has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Locker Content (locker-content) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/locker-content (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/locker-content"><img src="https://laskyr.com/plugins/locker-content/badge.svg" alt="Locker Content vulnerability status"></a>