Skip to content
Laskyr

Plugins · locatoraid · data as of 2026-11-04

Is Locatoraid Store Locator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.74)

As of 2026-11-04. 9 issues are on record for older versions; version 3.9.73 or newer fixes all of them that state a fix.

Latest version
3.9.74
Last updated
2026-10-27
Active installs
1,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.3+

A lightweight, reliable store locator backed by ongoing maintenance, updates, and support. Premium version adds CSV import, custom fields, custom map … — by plainware

What to do

  1. Update to the latest version (3.9.74). Anything older than 3.9.73 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get locatoraid --field=version shows what you run; wp plugin update locatoraid updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.3 CVE-2026-66680 · published 2026-08-20

SQL injection in Locatoraid Store Locator (3.9.72 and older)

Affected
3.9.72 and older
Fixed in
3.9.73 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in Locatoraid Store Locator <= 3.9.72 versions.

NVD CVE-2026-66680Patchstack advisory

medium 5.9 CVE-2025-62140 · published 2025-12-31

Stored cross-site scripting (XSS) in Locatoraid Store Locator (3.9.68 and older)

Affected
3.9.68 and older
Fixed in
3.9.70 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in plainware Locatoraid Store Locator locatoraid allows Stored XSS.This issue affects Locatoraid Store Locator: from n/a through <= 3.9.68.

NVD CVE-2025-62140Patchstack advisory

high 8.1 CVE-2024-56283 · published 2025-01-07

PHP object injection in Locatoraid Store Locator (3.9.50 and older)

Affected
3.9.50 and older
Fixed in
3.9.51
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in plainware Locatoraid Store Locator locatoraid allows Object Injection.This issue affects Locatoraid Store Locator: from n/a through <= 3.9.50.

NVD CVE-2024-56283Patchstack advisory

medium 6.1 CVE-2024-9652 · published 2024-10-16

Reflected cross-site scripting (XSS) in Locatoraid Store Locator (3.9.47 and older)

Affected
3.9.47 and older
Fixed in
3.9.48 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Locatoraid Store Locator plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via $_POST keys in all versions up to, and including, 3.9.47 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9652Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2024-30181 · published 2024-03-27

Stored cross-site scripting (XSS) in Locatoraid Store Locator (3.9.30 and older)

Affected
3.9.30 and older
Fixed in
3.9.31
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Plainware Locatoraid Store Locator allows Stored XSS.This issue affects Locatoraid Store Locator: from n/a through 3.9.30.

NVD CVE-2024-30181Patchstack advisory

medium 6.1 CVE-2023-4476 · published 2023-09-25

Reflected cross-site scripting (XSS) in Locatoraid Store Locator (older than 3.9.24)

Affected
older than 3.9.24
Fixed in
3.9.24
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Locatoraid Store Locator WordPress plugin before 3.9.24 does not sanitise and escape the lpr-search parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

NVD CVE-2023-4476WPScan advisory

medium 5.4 CVE-2023-32576 · published 2023-08-25

Stored cross-site scripting (XSS) in Locatoraid Store Locator (3.9.18 and older)

Affected
3.9.18 and older
Fixed in
3.9.19
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (subscriber+) Stored Cross-Site Scripting') vulnerability in Plainware Locatoraid Store Locator plugin <= 3.9.18 versions.

NVD CVE-2023-32576Patchstack advisory

medium 5.4 CVE-2023-2031 · published 2023-06-09

Stored cross-site scripting (XSS) in Locatoraid Store Locator (3.9.14 and older)

Affected
3.9.14 and older
Fixed in
3.9.19 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Locatoraid Store Locator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in versions up to, and including, 3.9.14 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-2031Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2023-25709 · published 2023-03-15

Cross-site request forgery (CSRF) in Locatoraid Store Locator (3.9.11 and older)

Affected
3.9.11 and older
Fixed in
3.9.12
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Plainware Locatoraid Store Locator plugin <= 3.9.11 versions.

NVD CVE-2023-25709Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Locatoraid Store Locator vulnerability status badge
<a href="https://laskyr.com/plugins/locatoraid"><img src="https://laskyr.com/plugins/locatoraid/badge.svg" alt="Locatoraid Store Locator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit