Skip to content
Laskyr

Plugins · location-weather · data as of 2026-11-04

Is Location Weather safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.0)

As of 2026-11-04. 3 issues are on record for older versions; version 3.0.7 or newer fixes all of them that state a fix.

Latest version
3.1.0
Last updated
2026-10-20
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Real-time Weather, Forecast, AQI, Weather Maps, Historical Data, Sun & Moon Times, AI Weather Assistant & Search – Block, Shortcode, Elementor. — by ShapedPlugin LLC

What to do

  1. Update to the latest version (3.1.0). Anything older than 3.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get location-weather --field=version shows what you run; wp plugin update location-weather updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-66433 · published 2026-07-27

Cross-site scripting (XSS) in Location Weather (3.0.6 and older)

Affected
3.0.6 and older
Fixed in
3.0.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Location Weather <= 3.0.6 versions.

NVD CVE-2026-66433Patchstack advisory

medium 4.3 CVE-2026-7249 · published 2026-05-22

Missing authorization check in Location Weather (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Location Weather plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability checks on the `splw_update_block_options()` and `lwp_clean_weather_transients()` functions in all versions up to, and including, 3.0.2. This makes it possible for authenticated attackers, with Contributor-level access and above, to disable all weather blocks and purge all weather cache transients. The nonce required for these actions is exposed to all authenticated users via `wp_localize_script()` on the `init` hook.

NVD CVE-2026-7249Wordfence advisorywordpress.orgPlugin source

medium 5.4 CVE-2023-0360 · published 2023-02-13

Stored cross-site scripting (XSS) in Location Weather (older than 1.3.4)

Affected
older than 1.3.4
Fixed in
1.3.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Location Weather WordPress plugin before 1.3.4 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

NVD CVE-2023-0360WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Location Weather vulnerability status badge
<a href="https://laskyr.com/plugins/location-weather"><img src="https://laskyr.com/plugins/location-weather/badge.svg" alt="Location Weather vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit