Plugins · local-sync · data as of 2026-11-04
Is WP Duplicate safe? Known vulnerabilities and latest version
- Latest version
- 1.1.11
- Last updated
- 2026-06-16
- Active installs
- 200+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8
Easily migrate or clone your WordPress Site from one host to another. — by revmakx
What to do
- There is no fixed version yet. If you can live without WP Duplicate for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get local-sync --field=version shows what you run; wp plugin update local-sync updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.9 affects latest 1.1.11 CVE-2026-39755 · published 2026-10-06
Arbitrary file upload in WP Duplicate (1.1.11 and older)
- Affected
- 1.1.11 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Arbitrary File Upload in WP Duplicate <= 1.1.11 versions.
high 8.8 CVE-2026-1499 · published 2026-02-06
Arbitrary file upload in WP Duplicate (1.1.8 and older)
- Affected
- 1.1.8 and older
- Fixed in
- 1.1.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Duplicate plugin for WordPress is vulnerable to Missing Authorization leading to Arbitrary File Upload in all versions up to and including 1.1.8. This is due to a missing capability check on the `process_add_site()` AJAX action combined with path traversal in the file upload functionality. This makes it possible for authenticated (subscriber-level) attackers to set the internal `prod_key_random_id` option, which can then be used by an unauthenticated attacker to bypass authentication checks and write arbitrary files to the server via the `handle_upload_single_big_file()` function, ultimately leading to remote code execution.
NVD CVE-2026-1499Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2025-24652 · published 2025-01-24
Missing authorization check in WP Duplicate (1.1.6 and older)
- Affected
- 1.1.6 and older
- Fixed in
- 1.1.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in revmakx WP Duplicate local-sync allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Duplicate: from n/a through <= 1.1.6.
Recent activity
- 2026-06-16 — latest release on wordpress.org (1.1.11).
- 2026-10-06 — Arbitrary file upload disclosed (CVE-2026-39755), no fix listed yet.
- 2026-02-06 — Arbitrary file upload disclosed (CVE-2026-1499), fixed in 1.1.9.
- 2025-01-24 — Missing authorization check disclosed (CVE-2025-24652), fixed in 1.1.7.
Get an email when WP Duplicate has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Duplicate (local-sync) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by revmakx (4 tracked)
Types found in this plugin: Arbitrary file upload (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/local-sync (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/local-sync"><img src="https://laskyr.com/plugins/local-sync/badge.svg" alt="WP Duplicate vulnerability status"></a>