Plugins · local-delivery-drivers-for-woocommerce · data as of 2026-11-04
Is Local Delivery Drivers for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.0.2
- Last updated
- 2026-09-27
- Active installs
- 800+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.0+
Add delivery drivers to WooCommerce, assign orders, plan routes, track deliveries, collect proof of delivery and send SMS & WhatsApp alerts. — by powerfulwp
What to do
- Update to the latest version (3.0.2). Anything older than 3.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get local-delivery-drivers-for-woocommerce --field=version shows what you run; wp plugin update local-delivery-drivers-for-woocommerce updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-66468 · published 2026-08-13
Cross-site scripting (XSS) in Local Delivery Drivers for WooCommerce (3.0.0 and older)
- Affected
- 3.0.0 and older
- Fixed in
- 3.0.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Local Delivery Drivers for WooCommerce <= 3.0.0 versions.
critical 9.8 CVE-2023-51481 · published 2024-05-17
Privilege escalation in Local Delivery Drivers for WooCommerce (1.9.0 and older)
- Affected
- 1.9.0 and older
- Fixed in
- 1.9.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Privilege Management vulnerability in powerfulwp Local Delivery Drivers for WooCommerce allows Privilege Escalation.This issue affects Local Delivery Drivers for WooCommerce: from n/a through 1.9.0.
Recent activity
- 2026-09-27 — latest release on wordpress.org (3.0.2).
- 2026-08-13 — Cross-site scripting (XSS) disclosed (CVE-2026-66468), fixed in 3.0.1.
- 2024-05-17 — Privilege escalation disclosed (CVE-2023-51481), fixed in 1.9.1.
Get an email when Local Delivery Drivers for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Local Delivery Drivers for WooCommerce (local-delivery-drivers-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/local-delivery-drivers-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/local-delivery-drivers-for-woocommerce"><img src="https://laskyr.com/plugins/local-delivery-drivers-for-woocommerce/badge.svg" alt="Local Delivery Drivers for WooCommerce vulnerability status"></a>