Skip to content
Laskyr

Plugins · liquid-speech-balloon · data as of 2026-11-04

Is LIQUID SPEECH BALLOON safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.7)

As of 2026-11-04. 3 issues are on record for older versions; version 1.2.6 or newer fixes all of them that state a fix.

Latest version
1.2.7
Last updated
2026-09-01
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Create a talk style (吹き出し) design in the block editor. — by lqd

What to do

  1. Update to the latest version (1.2.7). Anything older than 1.2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get liquid-speech-balloon --field=version shows what you run; wp plugin update liquid-speech-balloon updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-65527 · published 2026-07-23

Cross-site scripting (XSS) in LIQUID SPEECH BALLOON (1.2.5 and older)

Affected
1.2.5 and older
Fixed in
1.2.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in LIQUID SPEECH BALLOON <= 1.2.5 versions.

NVD CVE-2026-65527Patchstack advisory

high 8.8 CVE-2023-27889 · published 2023-05-10

Cross-site request forgery (CSRF) in LIQUID SPEECH BALLOON (older than 1.2)

Affected
older than 1.2
Fixed in
1.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site request forgery (CSRF) vulnerability in LIQUID SPEECH BALLOON versions prior to 1.2 allows a remote unauthenticated attacker to hijack the authentication of a user and to perform unintended operations by having a user view a malicious page.

NVD CVE-2023-27889wordpress.orgjvn.jp

medium 6.1 CVE-2019-17070 · published 2019-10-10

Cross-site scripting (XSS) in LIQUID SPEECH BALLOON (1.0.5 only)

Affected
1.0.5 only
Fixed in
1.0.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The liquid-speech-balloon (aka LIQUID SPEECH BALLOON) plugin before 1.0.7 for WordPress allows XSS with Internet Explorer.

NVD CVE-2019-17070wordpress.orggist.github.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
LIQUID SPEECH BALLOON vulnerability status badge
<a href="https://laskyr.com/plugins/liquid-speech-balloon"><img src="https://laskyr.com/plugins/liquid-speech-balloon/badge.svg" alt="LIQUID SPEECH BALLOON vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit