Skip to content
Laskyr

Plugins · linksy-search-and-replace · data as of 2026-11-04

Is Linksy Search and Replace safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.5)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.5 or newer fixes all of them that state a fix.

Latest version
1.0.5
Last updated
2026-07-24
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

A plugin to search and update URLs, Anchors, Titles and more on your site without digging into your database. — by Plugli

What to do

  1. Update to the latest version (1.0.5). Anything older than 1.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get linksy-search-and-replace --field=version shows what you run; wp plugin update linksy-search-and-replace updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-2941 · published 2026-03-21

Privilege escalation in Linksy Search and Replace (1.0.4 and older)

Affected
1.0.4 and older
Fixed in
1.0.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Linksy Search and Replace plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'linksy_search_and_replace_item_details' function in all versions up to, and including, 1.0.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to update any database table, any value, including the wp_capabilities database field, which allows attackers to change their own role to administrator, which leads to privilege escalation.

NVD CVE-2026-2941Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Linksy Search and Replace vulnerability status badge
<a href="https://laskyr.com/plugins/linksy-search-and-replace"><img src="https://laskyr.com/plugins/linksy-search-and-replace/badge.svg" alt="Linksy Search and Replace vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit