Skip to content
Laskyr

Plugins · link-hopper · data as of 2026-11-04

Is Link Hopper safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0)

As of 2026-11-04. 1 issue is on record for older versions; version 3.0 or newer fixes all of them that state a fix.

Latest version
3.0
Last updated
2026-03-08
Active installs
100+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.3+

Link Hopper lets you set up tidy link redirection to other websites. — by Anthony

What to do

  1. Update to the latest version (3.0). Anything older than 3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get link-hopper --field=version shows what you run; wp plugin update link-hopper updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2025-15483 · published 2026-02-14

Stored cross-site scripting (XSS) in Link Hopper (2.5 and older)

Affected
2.5 and older
Fixed in
3.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Link Hopper plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘hop_name’ parameter in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-15483Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Link Hopper vulnerability status badge
<a href="https://laskyr.com/plugins/link-hopper"><img src="https://laskyr.com/plugins/link-hopper/badge.svg" alt="Link Hopper vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit