Plugins · limit-login-attempts-reloaded · data as of 2026-11-01
Is Limit Login Attempts Security safe? Known vulnerabilities and latest version
- Latest version
- 3.3.10
- Last updated
- 2026-09-23
- Active installs
- 1+ million
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
WordPress login security with brute force protection, Two-factor authentication (2FA/MFA), firewall, IP/country blocking, and login monitoring — by WPChef
What to do
- Update to the latest version (3.3.10). Anything older than 3.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get limit-login-attempts-reloaded --field=version shows what you run; wp plugin update limit-login-attempts-reloaded updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 3.7 CVE-2026-18356 · published 2026-08-21
Security issue in Limit Login Attempts Security (older than 3.3.5)
- Affected
- older than 3.3.5
- Fixed in
- 3.3.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Limit Login Attempts Reloaded WordPress plugin before 3.3.5 does not compare logins against its username denylist case-insensitively and does not account for the account's email address, allowing an account an administrator intended to block from logging in to authenticate anyway.
medium 5.4 CVE-2023-6934 · published 2024-01-11
Stored cross-site scripting (XSS) in Limit Login Attempts Security (2.25.26 and older)
- Affected
- 2.25.26 and older
- Fixed in
- 2.25.27 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Limit Login Attempts Reloaded plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 2.25.26 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2023-6934Wordfence advisoryCode change (fix)plugins.svn.wordpress.org
critical 9.8 CVE-2020-35590 · published 2020-12-21
Security issue in Limit Login Attempts Security (older than 2.17.4)
- Affected
- older than 2.17.4
- Fixed in
- 2.17.4
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
LimitLoginAttempts.php in the limit-login-attempts-reloaded plugin before 2.17.4 for WordPress allows a bypass of (per IP address) rate limits because the X-Forwarded-For header can be forged. When the plugin is configured to accept an arbitrary header for the client source IP address, a malicious user is not limited to perform a brute force attack, because the client IP header accepts any arbitrary string. When randomizing the header input, the login count does not ever reach the maximum allowed retries.
medium 5.4 CVE-2020-35589 · published 2020-12-21
Cross-site scripting (XSS) in Limit Login Attempts Security (older than 2.17.4)
- Affected
- older than 2.17.4
- Fixed in
- 2.17.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The limit-login-attempts-reloaded plugin before 2.17.4 for WordPress allows wp-admin/options-general.php?page=limit-login-attempts&tab= XSS. A malicious user can cause an administrator user to supply dangerous content to the vulnerable page, which is then reflected back to the user and executed by the web browser. The most common mechanism for delivering malicious content is to include it as a parameter in a URL that is posted publicly or e-mailed directly to victims.
Recent activity
- 2026-09-23 — latest release on wordpress.org (3.3.10).
- 2026-08-21 — Security issue disclosed (CVE-2026-18356), fixed in 3.3.5.
- 2024-01-11 — Stored cross-site scripting (XSS) disclosed (CVE-2023-6934), fixed in 2.25.27.
- 2020-12-21 — Security issue disclosed (CVE-2020-35590), fixed in 2.17.4.
Get an email when Limit Login Attempts Security has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Limit Login Attempts Security (limit-login-attempts-reloaded) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/limit-login-attempts-reloaded (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/limit-login-attempts-reloaded"><img src="https://laskyr.com/plugins/limit-login-attempts-reloaded/badge.svg" alt="Limit Login Attempts Security vulnerability status"></a>