Skip to content
Laskyr

Plugins · lightsyncpro · data as of 2026-11-04

Is LightSync Pro safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.8)

As of 2026-11-04. 1 issue is on record for older versions; version 2.1.7 or newer fixes all of them that state a fix.

Latest version
2.1.8
Last updated
2026-05-21
Active installs
30+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Cloud-to-CMS image synchronization for WordPress & Shopify. Connect Lightroom, Canva, Figma, Dropbox, Shutterstock or generate with AI models — up … — by lightsyncpro

What to do

  1. Update to the latest version (2.1.8). Anything older than 2.1.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get lightsyncpro --field=version shows what you run; wp plugin update lightsyncpro updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-6147 · published 2026-08-05

Arbitrary file upload in LightSync Pro (2.1.6 and older)

Affected
2.1.6 and older
Fixed in
2.1.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The LightSync Pro plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the rest_replace_media() function in all versions up to, and including, 2.1.6. This makes it possible for authenticated attackers, with Author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2026-6147Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
LightSync Pro vulnerability status badge
<a href="https://laskyr.com/plugins/lightsyncpro"><img src="https://laskyr.com/plugins/lightsyncpro/badge.svg" alt="LightSync Pro vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit