Skip to content
Laskyr

Plugins · lightbox-block · data as of 2026-11-04

Is All In One Lightbox safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.2)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.1 or newer fixes all of them that state a fix.

Latest version
1.2.2
Last updated
2026-10-27
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Lightbox Block lets you display images, audio, video, and custom content in responsive lightbox galleries or media popups. — by bPlugins

What to do

  1. Update to the latest version (1.2.2). Anything older than 1.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get lightbox-block --field=version shows what you run; wp plugin update lightbox-block updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-116395 · published 2026-10-26

Stored cross-site scripting (XSS) in All In One Lightbox (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins LightBox Block lightbox-block allows Stored XSS.This issue affects LightBox Block: from n/a through 1.2.0.

NVD CVE-2026-116395Patchstack advisory

medium 6.5 CVE-2025-54051 · published 2025-07-16

Stored cross-site scripting (XSS) in All In One Lightbox (1.1.30 and older)

Affected
1.1.30 and older
Fixed in
1.1.31
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins LightBox Block lightbox-block allows Stored XSS.This issue affects LightBox Block: from n/a through <= 1.1.30.

NVD CVE-2025-54051Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
All In One Lightbox vulnerability status badge
<a href="https://laskyr.com/plugins/lightbox-block"><img src="https://laskyr.com/plugins/lightbox-block/badge.svg" alt="All In One Lightbox vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit