Skip to content
Laskyr

Plugins · library-management-system · data as of 2026-11-04

Is Library Management System safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.7.2)

As of 2026-11-04. 7 issues are on record for older versions; version 3.6.7 or newer fixes all of them that state a fix.

Latest version
3.7.2
Last updated
2026-10-19
Active installs
200+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

The best library management system plugin for WordPress — manage books, borrowers, branches, bookcases, sections, borrow/return workflows and receipts … — by Online Web Tutor

What to do

  1. Update to the latest version (3.7.2). Anything older than 3.6.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get library-management-system --field=version shows what you run; wp plugin update library-management-system updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-18666 · published 2026-08-10

SQL injection in Library Management System (older than 3.6.7)

Affected
older than 3.6.7
Fixed in
3.6.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Library Management System WordPress plugin before 3.6.7 does not sanitize and escape a user-supplied parameter before using it in a SQL statement, allowing users with a role as low as Subscriber to perform SQL injection and extract arbitrary data from the database, including user password hashes.

NVD CVE-2026-18666WPScan advisory

high 8.6 CVE-2026-12582 · published 2026-07-13

SQL injection in Library Management System (3.5 up to (not including) 3.5.8)

Affected
3.5 up to (not including) 3.5.8
Fixed in
3.5.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Library Management System WordPress plugin before 3.5.8 does not sanitize and escape a user-supplied parameter before using it in a SQL statement, allowing unauthenticated attackers to perform SQL injection and extract arbitrary data from the database, including user password hashes.

NVD CVE-2026-12582WPScan advisory

critical 9.3 CVE-2026-56034 · published 2026-06-26

SQL injection in Library Management System (3.5.7 and older)

Affected
3.5.7 and older
Fixed in
3.5.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in Library Management System <= 3.5.7 versions.

NVD CVE-2026-56034Patchstack advisory

high 7.5 CVE-2025-12707 · published 2026-02-19

SQL injection in Library Management System (3.2.1 and older)

Affected
3.2.1 and older
Fixed in
3.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Library Management System plugin for WordPress is vulnerable to SQL Injection via the 'bid' parameter in all versions up to, and including, 3.2.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-12707Wordfence advisoryCode change (fix)

medium 4.3 CVE-2025-10303 · published 2025-10-15

Missing authorization check in Library Management System (3.1 and older)

Affected
3.1 and older
Fixed in
3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Library Management System plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the owt7_library_management_ajax_handler() function in all versions up to, and including, 3.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update and manipulate several of the plugin's settings and features.

NVD CVE-2025-10303Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-12406 · published 2024-12-12

SQL injection in Library Management System (3.2.0 and older)

Affected
3.2.0 and older
Fixed in
3.2.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Library Management System – Manage e-Digital Books Library plugin for WordPress is vulnerable to SQL Injection via the 'owt7_borrow_books_id' parameter in all versions up to, and including, 3.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-12406Wordfence advisoryCode change (fix)Plugin source

medium 6.8 CVE-2024-8679 · published 2024-12-07

SQL injection in Library Management System (3.1 and older)

Affected
3.1 and older
Fixed in
3.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Library Management System – Manage e-Digital Books Library plugin for WordPress is vulnerable to SQL Injection via the ‘value' parameter of the owt_lib_handler AJAX action in all versions up to, and including, 3.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-8679Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Library Management System vulnerability status badge
<a href="https://laskyr.com/plugins/library-management-system"><img src="https://laskyr.com/plugins/library-management-system/badge.svg" alt="Library Management System vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit